码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2309 BST

时间:2017-07-12 18:53:14      阅读:188      评论:0      收藏:0      [点我收藏+]

标签:contains   ssi   each   desc   fine   分享   ret   continue   turn   

BST
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 10198   Accepted: 6216

Description

Consider an infinite full binary search tree (see the figure below), the numbers in the nodes are 1, 2, 3, .... In a subtree whose root node is X, we can get the minimum number in this subtree by repeating going down the left node until the last level, and we can also find the maximum number by going down the right node. Now you are given some queries as "What are the minimum and maximum numbers in the subtree whose root node is X?" Please try to find answers for there queries.
技术分享

Input

In the input, the first line contains an integer N, which represents the number of queries. In the next N lines, each contains a number representing a subtree with root number X (1 <= X <= 231 - 1).

Output

There are N lines in total, the i-th of which contains the answer for the i-th query.

Sample Input

2
8
10

Sample Output

1 15
9 11
//刚开始以为只有偶数,结果tle
//又以为只有一个奇数,结果wa。
//。。。。。。无语了。。。
//lowbit水过
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;
#define lowbit(x) x&(-x)
#define max(x,y) (x>y?x:y)
#define min(x,y) (x<y?x:y)
#define mem(a) (memset(a,0,sizeof(a)))
typedef long long ll;
ll n;
void slow(ll n,ll x)
{
    while(x!=1)
    {
        x=lowbit(x);
        x/=2;
        n-=x;
    }
    printf("%lld ",n);
}
void add(ll n,ll x)
{
    while(x!=1)
    {
        x=lowbit(x);
        x/=2;
        n+=x;
    }
    printf("%lld\n",n);
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld",&n);
        if(n%2==1) {cout<<n<< <<n<<endl;continue;}
        slow(n,n);
        add(n,n);
    }
    return 0;
}

 

 

POJ 2309 BST

标签:contains   ssi   each   desc   fine   分享   ret   continue   turn   

原文地址:http://www.cnblogs.com/shinianhuanniyijuhaojiubujian/p/7156671.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!