码迷,mamicode.com
首页 > 其他好文 > 详细

Brackets(区间dp)

时间:2017-07-12 23:09:30      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:strlen   output   nbsp   find   tput   sequence   []   sse   cal   

Brackets
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8017   Accepted: 4257

Description

We give the following inductive definition of a “regular brackets” sequence:

  • the empty sequence is a regular brackets sequence,
  • if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
  • if a and b are regular brackets sequences, then ab is a regular brackets sequence.
  • no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1i2, …, im where 1 ≤i1 < i2 < … < im ≤ nai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters ()[, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source

【题目大意】
最大括号匹配
【思路】
区间dp 枚举长度
【code】
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char s[101];
int dp[101][101];
int main()
{
    while(gets(s)!=NULL)
    {
        if(s[0]==e)break;
        memset(dp,0,sizeof(dp));
        int len=strlen(s);
        for(int i=1;i<=len;i++)
        for(int j=0,k=i;k<=len;j++,k++)
        {
            if(s[j]==(&&s[k]==)||s[j]==[&&s[k]==])
            dp[j][k]=dp[j+1][k-1]+2;
            for(int p=j;p<=k;p++)
            dp[j][k]=max(dp[j][k],dp[j][p]+dp[p+1][k]);
        }
        printf("%d\n",dp[0][len-1]);
    }
    return 0;
}

 

  

Brackets(区间dp)

标签:strlen   output   nbsp   find   tput   sequence   []   sse   cal   

原文地址:http://www.cnblogs.com/zzyh/p/7157800.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!