码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 3652 B-number

时间:2017-07-13 01:04:37      阅读:243      评论:0      收藏:0      [点我收藏+]

标签:space   ++   http   lin   int   contain   sea   test   man   

B-number

http://acm.hdu.edu.cn/showproblem.php?pid=3652

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Problem Description
A wqb-number, or B-number for short, is a non-negative integer whose decimal form contains the sub- string "13" and can be divided by 13. For example, 130 and 2613 are wqb-numbers, but 143 and 2639 are not. Your task is to calculate how many wqb-numbers from 1 to n for a given integer n.
 
Input
Process till EOF. In each line, there is one positive integer n(1 <= n <= 1000000000).
 
Output
Print each answer in a single line.
 
Sample Input
13
100
200
1000
 
Sample Output
1
1
2
2
 
Author
wqb0039
 
Source
 
Recommend
lcy   |   We have carefully selected several similar problems for you:  3651 3655 3654 3653 3659 
 
数位DP
#include<cstdio>
#include<cstring>
using namespace std;
int a[20],pos,dp[20][3][13];
int dfs(int dep,int type,int mod,bool lim)
{
    if(!dep) return type==2 && !mod;
    if(!lim && dp[dep][type][mod]!=-1) return dp[dep][type][mod];
    int ans=0,up= lim ? a[dep] : 9;
    for(int i=0;i<=up;i++)
    {
        if(type==2 || (type==1 && i==3)) ans+=dfs(dep-1,2,(mod*10+i)%13,lim && i==up);
        else ans+=dfs(dep-1,i==1 ? 1 : 0,(mod*10+i)%13,lim && i==up);
    } 
    if(!lim) dp[dep][type][mod]=ans;
     return ans;
}
int solve(int n)
{
    while(n) { a[++pos]=n%10; n/=10; }
    return dfs(pos,0,0,1);
}
int main()
{
    int n;
    memset(dp,-1,sizeof(dp));
    while(scanf("%d",&n)!=EOF)
    {
        printf("%d\n",solve(n));
        pos=0;
    }
}

 

hdu 3652 B-number

标签:space   ++   http   lin   int   contain   sea   test   man   

原文地址:http://www.cnblogs.com/TheRoadToTheGold/p/7157958.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!