码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1026 Cipher

时间:2017-07-13 21:55:36      阅读:227      评论:0      收藏:0      [点我收藏+]

标签:inpu   not   一个   into   put   integer   ever   poj   star   

Description

Bob and Alice started to use a brand-new encoding scheme. Surprisingly it is not a Public Key Cryptosystem, but their encoding and decoding is based on secret keys. They chose the secret key at their last meeting in Philadelphia on February 16th, 1996. They chose as a secret key a sequence of n distinct integers, a1 ; . . .; an, greater than zero and less or equal to n. The encoding is based on the following principle. The message is written down below the key, so that characters in the message and numbers in the key are correspondingly aligned. Character in the message at the position i is written in the encoded message at the position ai, where ai is the corresponding number in the key. And then the encoded message is encoded in the same way. This process is repeated k times. After kth encoding they exchange their message. 

The length of the message is always less or equal than n. If the message is shorter than n, then spaces are added to the end of the message to get the message with the length n. 

Help Alice and Bob and write program which reads the key and then a sequence of pairs consisting of k and message to be encoded k times and produces a list of encoded messages. 

Input

The input file consists of several blocks. Each block has a number 0 < n <= 200 in the first line. The next line contains a sequence of n numbers pairwise distinct and each greater than zero and less or equal than n. Next lines contain integer number k and one message of ascii characters separated by one space. The lines are ended with eol, this eol does not belong to the message. The block ends with the separate line with the number 0. After the last block there is in separate line the number 0.

Output

Output is divided into blocks corresponding to the input blocks. Each block contains the encoded input messages in the same order as in input file. Each encoded message in the output file has the lenght n. After each block there is one empty line.

Sample Input

10
4 5 3 7 2 8 1 6 10 9
1 Hello Bob
1995 CERC
0
0

Sample Output

BolHeol  b
C RCE

分析
该题容易Time Limit Exceeded 或Presentation Error。
TLE的解决方式:加密数组的每一位在多次加密后就会回到原先的位置,即发生循环(如a[]= {2,3,4,5,6,7,8},加密n次就会恢复到初始位置),因此算出每一块的每一位循环长度(注意是每一位,
因为加密数组内的移动不一定都有相同的循环)将其保存在一个数组中(代码中为p数组),将循环内的结果存放在queue[i][k]中(第i位加密k次的位置)。
代码
#include <cstdio>
#include <cstring>
int a[202];
int p[202];
int queue[202][202];
char source[202];
char changeTo[202];
int main(){
    int n,t;
    char ch;
    while(true){
        scanf("%d",&n);
        if(n == 0)break;
        for(int i = 1;i <= n;i++)
            scanf("%d",&a[i]);
        for (int i = 1; i <= n; ++i) {
            p[i] = 1;
            queue[i][1] = i;
        }
        for(int i = 1;i <= n;i++){
            int k = 2;
            while(true){
                queue[i][k] = a[queue[i][k-1]];
                if(queue[i][k] == i){
                    break;
                }else{
                    ++k;
                    ++p[i];
                }
            }
        }
        while(true){
            scanf("%d",&t);
            if(t == 0)break;
            memset(changeTo, ,sizeof(changeTo));
            int e = 1;
            getchar();
            while((ch = getchar())!= \n)source[e++] = ch;
            for(int i = e;i <= n;i++)
                source[i] =  ;
            for(int i = 1;i <= n;i++){
                int k = (t % p[i])+1;
                changeTo[queue[i][k]] = source[i];
            }
            changeTo[n+1] = 0;
            printf("%s\n",changeTo+1);
        }
        printf("\n");
    }
}

 



POJ1026 Cipher

标签:inpu   not   一个   into   put   integer   ever   poj   star   

原文地址:http://www.cnblogs.com/starryxsky/p/7162328.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!