码迷,mamicode.com
首页 > 其他好文 > 详细

[poj]1050 To the Max dp

时间:2017-07-16 20:17:55      阅读:181      评论:0      收藏:0      [点我收藏+]

标签:order   int   lang   连续   mem   oca   row   inf   its   

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

和最大连续子串和类似,可以把二维的转化为一维,将i行到j行的各列数分别相加,求最大连续子串和即可。
同时可利用前缀和,sum[i][j]表示第j列前i行相加的和,i从1开始,则i-j行相加的和为sum[j][k]-sum[i-1][k]
#include <iostream>
#include <stdio.h>
#include <cstring>
#include <algorithm>
using namespace std;

#define INF 0x3f3f3f3f
int a[110][110];
int t[110], dp[110];
int sum[110][110];

int n;

int sovle()
{
    int ans = -INF;
    for (int i = 1; i <= n; i++) {
        for (int j = i; j <= n; j++) {

            int Max;
            dp[1] = sum[j][1] - sum[i-1][1];
            for (int k = 1; k <= n; k++) {
                int temp = sum[j][k]-sum[i-1][k];
                dp[k] = max(dp[k-1]+temp, temp);
            }
            Max = *max_element(dp+1, dp+n+1);
            if (Max > ans)
                ans = Max;
        }
    }
    return ans;
}

int main()
{
    //freopen("1.txt", "r", stdin);
    scanf("%d", &n);
    memset(sum, 0, sizeof(sum));
    for (int i = 1; i <= n; i++)
        for (int j = 1; j <= n; j++) {
            scanf("%d", &a[i][j]);
            sum[i][j] = sum[i-1][j] + a[i][j];
        }
    printf("%d\n", sovle());

    return 0;
}

 

 

[poj]1050 To the Max dp

标签:order   int   lang   连续   mem   oca   row   inf   its   

原文地址:http://www.cnblogs.com/whileskies/p/7191428.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!