码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1241 DFS

时间:2017-07-17 00:31:42      阅读:277      评论:0      收藏:0      [点我收藏+]

标签:rate   win   divide   else   using   ott   cin   diagonal   max   

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31745    Accepted Submission(s): 18440


Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 
 

 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*‘, representing the absence of oil, or `@‘, representing an oil pocket.
 

 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
 

 

Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0
Sample Output
0
1
2
2

 题意 求连通块 八个方向

最基础 dfs

AC代码

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<cmath>
#include<algorithm>
#define maxn 105
using namespace std;
int fangxiang[8][2]={{0,1},{0,-1},{-1,0},{1,0},{-1,-1},{1,1},{1,-1},{-1,1}};  //八个方向
char visit[maxn][maxn];
char mapn[maxn][maxn];
int n,m;
void dfs(int x,int y)
{
    if(x>=1&&x<=n&&y>=1&&y<=m)             //注意边界
    {
        if(mapn[x][y]==@)                //覆盖掉已经遍历到的点
        {
            mapn[x][y]=*;
            for(int i=0; i<8; i++)
            {
                dfs(x+fangxiang[i][0],y+fangxiang[i][1]);
            }
        }
    }
    else
        return;
}
int main()
{
    int i,j,k;
    while(scanf("%d%d",&n,&m)&&n)
    {
        int sum=0;
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
                cin>>mapn[i][j];
        }
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=m;j++)
            {
                if(mapn[i][j]==@)
                {
                    dfs(i,j);
                    sum++;
                }
            }
        }
        printf("%d\n",sum);
    }
}

 

HDU 1241 DFS

标签:rate   win   divide   else   using   ott   cin   diagonal   max   

原文地址:http://www.cnblogs.com/stranger-/p/7192366.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!