码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2192 MagicBuilding

时间:2017-07-18 23:05:44      阅读:245      评论:0      收藏:0      [点我收藏+]

标签:people   ++   code   height   div   mission   math   esc   class   

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2418    Accepted Submission(s): 1088


Problem Description
As the increase of population, the living space for people is becoming smaller and smaller. In MagicStar the problem is much worse. Dr. Mathematica is trying to save land by clustering buildings and then we call the set of buildings MagicBuilding. Now we can treat the buildings as a square of size d, and the height doesn‘t matter. Buildings of d1,d2,d3....dn can be clustered into one MagicBuilding if they satisfy di != dj(i != j).
Given a series of buildings size , you need to calculate the minimal numbers of MagicBuildings that can be made. Note that one building can also be considered as a MagicBuilding.
Suppose there are five buildings : 1, 2, 2, 3, 3. We make three MagicBuildings (1,3), (2,3), (2) .And we can also make two MagicBuilding :(1,2,3), (2,3). There is at least two MagicBuildings obviously.
 

 

Input
The first line of the input is a single number t, indicating the number of test cases.
Each test case starts by n (1≤n≤10^4) in a line indicating the number of buildings. Next n positive numbers (less than 2^31) will be the size of the buildings.
 

 

Output
For each test case , output a number perline, meaning the minimal number of the MagicBuilding that can be made.
 

 

Sample Input
2 1 2 5 1 2 2 3 3
 

 

Sample Output
1 2
 

 

Author
scnu
 

 

Recommend
 
题目大意 :
高度不同的可以合并为一个楼,问最少能合并成多少楼
简单模拟 
#include <algorithm>
#include <cstdio>

using namespace std;
int maxn,ans,t,n,buil[10005];
int main()
{
    scanf("%d",&t);
    for(;t--;)
    {
        maxn=ans=1;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&buil[i]);
        sort(buil+1,buil+1+n);
        for(int i=2;i<=n;i++)
        {
            if(buil[i]==buil[i-1])
                ans++;
            else 
            {
                if(ans>maxn) maxn=ans;
                ans=1;
            }
        }
        if(ans>maxn) maxn=ans;
        printf("%d\n",maxn);
    }
    return 0;
}

 

hdu 2192 MagicBuilding

标签:people   ++   code   height   div   mission   math   esc   class   

原文地址:http://www.cnblogs.com/ruojisun/p/7203113.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!