码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3535 AreYouBusy(组合背包)

时间:2017-07-18 23:16:15      阅读:347      评论:0      收藏:0      [点我收藏+]

标签:inpu   全局   scanf   strong   accept   always   less   microsoft   ret   

传送门

AreYouBusy

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4362    Accepted Submission(s): 1761

Description

Happy New Term!
As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.
What‘s more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as "jobs". A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss‘s advice)?

Input

There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.

Output

One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .

Sample Input

3 3
2 1
2 5
3 8
2 0
1 0
2 1
3 2
4 3
2 1
1 1

3 4
2 1
2 5
3 8
2 0
1 1
2 8
3 2
4 4
2 1
1 1

1 1
1 0
2 1

5 3
2 0
1 0
2 1
2 0
2 2
1 1
2 0
3 2
2 1
2 1
1 5
2 8
3 2
3 8
4 9
5 10

Sample Output

5
13
-1
-1

思路

题意:有n类工作,给定时间T,每类工作有m种事情,第0类表示至少选一件事做,第1类表示至多选一件事做,第2类表示你可以自由选择。给出每件事所需的时间c以及完成事件后得到的成就感g。问在时间T内,按照规定的要求,所能获得的最大成就是多少。

思路:dp[i][j]表示第 i 组,时间 j 能获得的最大成就。

第一类:至少选一项,因此初始化的时候d,这一组的dp值全部赋值为-INF,dp[i - 1][j - c] + v 表示第一次选择本组中的物品。由于开始时将该组dp赋值-INF,所以第一次取时,必须由上一组的结果推知,这样才能保证得到全局最优解;

第二类:最多选一项,要么不选,要么一组只能选择一项。因此转移方程容易写出 dp[i][j] = max(dp[i][j],dp[i-1][j-c] + v)。由于要保证得到全局最优解,所以在该组DP开始以前,应该将上一组的DP结果先复制到这一组的dp[i]数组里,因为当前组的数据是在上一组数据的基础上进行更新的。

第三类就是简单的01背包问题。同样,为了保证全局最优解,要先复制上一组的解。

 

#include<bits/stdc++.h>
using namespace std;
const int INF = (1<<30);
const int maxn = 105;
int dp[maxn][maxn];

int main()
{
	//freopen("input.txt","r",stdin);
	int n,T;
	while (~scanf("%d%d",&n,&T))
	{
		int m,s,c,v;
		memset(dp,0,sizeof(dp));
		for (int i = 1;i <= n;i++)
		{
			scanf("%d%d",&m,&s);
			if (s == 0)
			{
				for (int j = 0;j <= T;j++)	dp[i][j] = -INF;
				while (m--)
				{
					scanf("%d%d",&c,&v);
					for (int j = T;j >= c;j--)
					{
						dp[i][j] = max(dp[i][j],max(dp[i-1][j-c] + v,dp[i][j-c] + v));
					}
				}
			}
			else if (s == 1)
			{
				for (int j = 0;j <= T;j++)	dp[i][j] = dp[i-1][j];
				while (m--)
				{
					scanf("%d%d",&c,&v);
					for (int j = T;j >= c;j--)
					{
						dp[i][j] = max(dp[i][j],dp[i-1][j-c] + v);
						//注意以下顺序是错误的,因为当c = 0时,dp[i][j]会加两次v 
						//dp[i][j] = max(dp[i][j],dp[i-1][j-c] + v);
                        //dp[i][j] = max(dp[i][j],dp[i][j-c] + v);
					}
				}
			}
			else if (s == 2)
			{
				for (int j = 0;j <= T;j++)	dp[i][j] = dp[i-1][j];
				while (m--)
				{
					scanf("%d%d",&c,&v);
					for (int j = T;j >=c;j--)
					{
						dp[i][j] = max(dp[i][j],dp[i][j-c] + v);
						dp[i][j] = max(dp[i][j],dp[i-1][j-c] + v);
					}
				}
			}
		}
		printf("%d\n",max(dp[n][T],-1));
	}
	return 0;
} 

  

HDU 3535 AreYouBusy(组合背包)

标签:inpu   全局   scanf   strong   accept   always   less   microsoft   ret   

原文地址:http://www.cnblogs.com/zzy19961112/p/7202811.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!