码迷,mamicode.com
首页 > 其他好文 > 详细

Big Number

时间:2017-07-20 12:50:34      阅读:140      评论:0      收藏:0      [点我收藏+]

标签:out   clu   ble   really   new   cal   always   case   eal   

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)

Total Submission(s) : 34   Accepted Submission(s) : 24
Problem Description
As we know, Big Number is always troublesome. But it‘s really important in our ACM. And today, your task is to write a program to calculate A mod B. To make the problem easier, I promise that B will be smaller than 100000. Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 
Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 
Output
For each test case, you have to ouput the result of A mod B.
 
Sample Input
2 3 12 7 152455856554521 3250
 

Sample Output
2 5 1521
 







#include<stdio.h>
#include<string.h>
char x[1000000];
int main()
{
    int n,i,j,k,a,b,c;
    while(scanf("%s%d",x,&n)!=EOF)
    {
       a=0;
       for(i=0;i<strlen(x);i++)
       {
         a=a*10+x[i]-‘0‘;
         a=a%n;    
       }
       printf("%d\n",a);
    }
    return 0;
}

Big Number

标签:out   clu   ble   really   new   cal   always   case   eal   

原文地址:http://www.cnblogs.com/mthoutai/p/7210518.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!