码迷,mamicode.com
首页 > 其他好文 > 详细

Stones 优先队列

时间:2017-07-21 15:53:03      阅读:134      评论:0      收藏:0      [点我收藏+]

标签:operator   contain   from   wrong   tle   time   ++   blog   出发点   

Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time.
There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.

InputIn the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases.
For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position of the i-th stone and how far Sempr can throw it.
OutputJust output one line for one test case, as described in the Description.
Sample Input
2
2
1 5
2 4
2
1 5
6 6
Sample Output
11
12

题意是求从出发点到最后一块石头的距离,遇到奇数石头可以扔,偶数不管,那么就是创建优先队列,扔出去的,按照扔出去以后的位置和原来能扔的距离入队就好了。不停直到队列为空。


代码:

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <queue>

using namespace std;

struct stone
{
    int loc,dis;
    friend bool operator <(stone a,stone b)
    {
        if(a.loc==b.loc)return a.dis>b.dis;
        return a.loc>b.loc;
    }
}temp,cn;
int main()
{
    int T,n,p,d,loca=0,c=0,maxi=0;
    priority_queue <stone>q;
    scanf("%d",&T);
    while(T--)
    {
        loca=c=maxi=0;
        scanf("%d",&n);
        for(int i=0;i<n;i++)
        {
            scanf("%d%d",&p,&d);
            temp.loc=p,temp.dis=d;
            q.push(temp);
        }
        while(!q.empty())
        {
            c++;
            cn=q.top();
            q.pop();
            if(loca<cn.loc)loca=cn.loc;
            if(c%2==1)
            {
                temp.loc=loca+cn.dis;
                if(maxi<temp.loc)maxi=temp.loc;
                temp.dis=cn.dis;
                q.push(temp);
            }
        }
        printf("%d\n",maxi>loca?maxi:loca);
    }
}

 

Stones 优先队列

标签:operator   contain   from   wrong   tle   time   ++   blog   出发点   

原文地址:http://www.cnblogs.com/8023spz/p/7217312.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!