码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 1317 XYZZY

时间:2014-05-09 22:57:45      阅读:360      评论:0      收藏:0      [点我收藏+]

标签:des   style   class   code   java   tar   


spfa找正环

XYZZY

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2344    Accepted Submission(s): 589


Problem Description
It has recently been discovered how to run open-source software on the Y-Crate gaming device. A number of enterprising designers have developed Advent-style games for deployment on the Y-Crate. Your job is to test a number of these designs to see which are winnable. 
Each game consists of a set of up to 100 rooms. One of the rooms is the start and one of the rooms is the finish. Each room has an energy value between -100 and +100. One-way doorways interconnect pairs of rooms. 

The player begins in the start room with 100 energy points. She may pass through any doorway that connects the room she is in to another room, thus entering the other room. The energy value of this room is added to the player‘s energy. This process continues until she wins by entering the finish room or dies by running out of energy (or quits in frustration). During her adventure the player may enter the same room several times, receiving its energy each time. 
 

Input
The input consists of several test cases. Each test case begins with n, the number of rooms. The rooms are numbered from 1 (the start room) to n (the finish room). Input for the n rooms follows. The input for each room consists of one or more lines containing: 

the energy value for room i 
the number of doorways leaving room i 
a list of the rooms that are reachable by the doorways leaving room i 
The start and finish rooms will always have enery level 0. A line containing -1 follows the last test case. 
 

Output
In one line for each case, output "winnable" if it is possible for the player to win, otherwise output "hopeless". 
 

Sample Input
5 0 1 2 -60 1 3 -60 1 4 20 1 5 0 0 5 0 1 2 20 1 3 -60 1 4 -60 1 5 0 0 5 0 1 2 21 1 3 -60 1 4 -60 1 5 0 0 5 0 1 2 20 2 1 3 -60 1 4 -60 1 5 0 0 -1
 

Sample Output
hopeless hopeless winnable winnable
 

Source
 


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>

using namespace std;

const int maxn=211;

vector<int> g[maxn];
int dist[maxn],inq[maxn],cq[maxn];
int vis[maxn],energy[maxn],n;

void dfs(int u)
{
    vis[u]=true;
    for(int i=0,sz=g[u].size();i<sz;i++)
    {
        int v=g[u][i];
        if(vis[v]) continue;
        dfs(v);
    }
}

bool spfa()
{
    memset(dist,0xcf,sizeof(dist));
    memset(inq,0,sizeof(inq));
    memset(cq,0,sizeof(cq));

    dist[1]=0;
    inq[1]=cq[1]=1;
    queue<int> q;
    q.push(1);

    while(!q.empty())
    {
        int u=q.front(); q.pop();
        for(int i=0,sz=g[u].size();i<sz;i++)
        {
            int v=g[u][i];
            int newvalue=dist[u]+energy[v];
            if(newvalue>-100)
            if(dist[v]<newvalue)
            {
                dist[v]=newvalue;
                if(inq[v]==0)
                {
                    inq[v]=1;
                    cq[v]++;
                    if(cq[v]>=n)
                    {
                        memset(vis,0,sizeof(vis));
                        dfs(v);
                        if(vis[n]) return true;
                        continue;
                    }
                    q.push(v);
                }
            }
        }
        inq[u]=0;
    }
    if(dist[n]>-100) return true;
    return false;
}

int main()
{
    int a,b,c;
    while(scanf("%d",&n)!=EOF&&~n)
    {
        for(int i=1;i<=n;i++)
        {
            g[i].clear();
            scanf("%d",energy+i);
            scanf("%d",&a);
            for(int j=1;j<=a;j++)
            {
                scanf("%d",&b);
                g[i].push_back(b);
            }
        }
        if(spfa()) puts("winnable");
        else puts("hopeless");
    }
    return 0;
}




HDOJ 1317 XYZZY,布布扣,bubuko.com

HDOJ 1317 XYZZY

标签:des   style   class   code   java   tar   

原文地址:http://blog.csdn.net/ck_boss/article/details/25406817

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!