标签:problem stdio.h string top art cout and not ret
InputYour program will be tested on one or more data sets. Each data set is described on a single line. The line is a non-empty string of opening and closing braces and nothing else. No string has more than 2000 braces. All sequences are of even length.
The last line of the input is made of one or more ’-’ (minus signs.)
OutputFor each test case, print the following line:
k. N
Where k is the test case number (starting at one,) and N is the minimum number of operations needed to convert the given string into a balanced one.
Note: There is a blank space before N.
Sample Input
}{ {}{}{} {{{} ---
Sample Output
1. 2 2. 0 3. 1
通过代码
#include<iostream>
#include<stdio.h>
#include<stack>
#include<string.h>
using namespace std;
int main()
{
char ch[2000];
stack<int>st;
int t=0;
while(++t)
{
gets(ch);
int leng=strlen(ch);
int jishu=0,sign=0;
for(int i=0;i<leng;i++)
{
if(ch[i]==‘-‘)
{
sign=1;
break;
}
if(ch[i]==‘{‘&&st.empty())
{
st.push(1);
continue;
}
if(ch[i]==‘{‘&&st.top()==1)
{
st.push(1);
continue;
}
if(ch[i]==‘}‘&&st.empty())
{
st.push(1);
jishu++;
continue;
}
if(ch[i]==‘}‘&&st.top()==1)
{
st.pop();
continue;
}
}
if(sign==1) break;
else
{
if(st.empty()) cout<<t<<". "<<jishu<<endl;
else cout<<t<<". "<<jishu+st.size()/2<<endl;
}
jishu=0; //每次做完循环计数归0
while(!st.empty()) st.pop(); //每次做完循环清空栈
}
}
标签:problem stdio.h string top art cout and not ret
原文地址:http://www.cnblogs.com/carry-2017/p/7220710.html