码迷,mamicode.com
首页 > 其他好文 > 详细

bzoj 1045: [HAOI2008] 糖果传递 贪心

时间:2014-09-02 17:29:04      阅读:146      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   io   for   数据   

1045: [HAOI2008] 糖果传递

Time Limit: 10 Sec  Memory Limit: 162 MB
Submit: 1812  Solved: 846
[Submit][Status]

Description

有n个小朋友坐成一圈,每人有ai个糖果。每人只能给左右两人传递糖果。每人每次传递一个糖果代价为1。

Input

小朋友个数n 下面n行 ai

Output

求使所有人获得均等糖果的最小代价。

Sample Input

4
1
2
5
4

Sample Output

4
数据规模
30% n<=1000
100% n<=1000000

HINT

 

Source

 http://www.cnblogs.com/wmrv587/p/3900279.html

突然发现做题是把模型简化是非常好的思路。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
#define MAXN 1000100
typedef long long qword;
qword num[MAXN],f[MAXN];
int main()
{
        freopen("input.txt","r",stdin);
        int n;
        scanf("%d",&n);
        int i,j,k;
        qword sum=0;
        for (i=0;i<n;i++)
        {
                scanf("%lld",&num[i]);
                sum+=num[i];
        }
        int base=sum/n;
        int x,y,z;
        f[0]=num[i]-base;
        for (i=1;i<n;i++)
        {
                f[i]=f[i-1]+num[i]-base;
        }
        sort(f,&f[n]);
        int mid=(n-1)/2;
        qword ans=0;
        for (i=0;i<n;i++)
        {
                ans+=abs(f[i]-f[mid]);
        }
        printf("%lld",ans);
        return 0;
}

 

 

bzoj 1045: [HAOI2008] 糖果传递 贪心

标签:des   style   blog   http   color   os   io   for   数据   

原文地址:http://www.cnblogs.com/mhy12345/p/3951814.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!