标签:des style blog color os io strong ar for
Black Box
Time Limit: 1000MS |
|
Memory Limit: 10000K |
Total Submissions: 7436 |
|
Accepted: 3050 |
Description
Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions:
ADD (x): put element x into Black Box;
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending.
Let us examine a possible sequence of 11 transactions:
Example 1
N Transaction i Black Box contents after transaction Answer
(elements are arranged by non-descending)
1 ADD(3) 0 3
2 GET 1 3 3
3 ADD(1) 1 1, 3
4 GET 2 1, 3 3
5 ADD(-4) 2 -4, 1, 3
6 ADD(2) 2 -4, 1, 2, 3
7 ADD(8) 2 -4, 1, 2, 3, 8
8 ADD(-1000) 2 -1000, -4, 1, 2, 3, 8
9 GET 3 -1000, -4, 1, 2, 3, 8 1
10 GET 4 -1000, -4, 1, 2, 3, 8 2
11 ADD(2) 4 -1000, -4, 1, 2, 2, 3, 8
It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type.
Let us describe the sequence of transactions by two integer arrays:
1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2).
2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6).
The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence
we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence.
Input
Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.
Output
Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.
Sample Input
7 4
3 1 -4 2 8 -1000 2
1 2 6 6
Sample Output
3
3
1
2
题意 :给出n,m,然后接下一行输入n个数,最后一行输入m个数,要求对于最后一行的第i个数,输出在原数列中前x个数中第i小的数,。好绕口,然后一开始用sort是各种TLE,好多大神用平衡树过的,差点没吓哭我,然后,。。撸了两个堆,一个最大堆,一个最小堆,注意维护好这两个堆,其中最大堆放前k个最小的数,最小堆放剩余的数,那么最大堆的堆顶就是第k个最小的数。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cctype>
#include <cstdlib>
#include <algorithm>
#include <set>
#include <vector>
#include <string>
#include <map>
#include <queue>
using namespace std;
const int maxn= 30010;
int a[maxn];
priority_queue <int,vector<int>,less<int> > maxQ;
priority_queue <int,vector<int>,greater<int> > minQ;
int main()
{
int n,m,x;
scanf("%d%d",&n,&m);
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
int pos=0;
for(int i=1;i<=m;i++)
{
scanf("%d",&x);
while(pos<x)
minQ.push(a[pos++]);//新加元素放入最小堆
while(maxQ.size()<i)//维护最大堆
{
maxQ.push(minQ.top());
minQ.pop();
}
while(!minQ.empty()&&maxQ.top()>minQ.top())//维护两个堆,严格保证maxQ.top()<=minQ.top()
{
int t1=maxQ.top(),t2=minQ.top();
maxQ.pop();minQ.pop();
maxQ.push(t2);minQ.push(t1);
}
printf("%d\n",maxQ.top());
}
return 0;
}
POJ 1442-Black Box(优先队列)
标签:des style blog color os io strong ar for
原文地址:http://blog.csdn.net/qq_16255321/article/details/39009005