码迷,mamicode.com
首页 > 其他好文 > 详细

UVA - 1476 Error Curves (三分搜索)

时间:2014-09-02 17:52:25      阅读:296      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   os   io   ar   for   art   div   

Description

bubuko.com,布布扣 Josephina is a clever girl and addicted to Machine Learning recently. She pays much attention to a method called Linear Discriminant Analysis, which has many interesting properties.

In order to test the algorithm‘s efficiency, she collects many datasets. What‘s more, each data is divided into two parts: training data and test data. She gets the parameters of the model on training data and test the model on test data.

To her surprise, she finds each dataset‘s test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the formf(x) = ax2 + bx + c. The quadratic will degrade to linear function ifa = 0.

bubuko.com,布布扣

It‘s very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function‘s minimal which related to multiple quadric functions.

The new function F(x) is defined as follow:

F(x) = max(Si(x)), i = 1...n. The domain ofx is [0, 1000]. Si(x) is a quadric function.

Josephina wonders the minimum of F(x). Unfortunately, it‘s too hard for her to solve this problem. As a super programmer, can you help her?

Input

The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n(n ≤ 10000). Followingn lines, each line contains three integers a (0 ≤ a ≤ 100),b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.

Output

For each test case, output the answer in a line. Round to 4 digits after the decimal point.

Sample Input

2
1
2 0 0
2
2 0 0
2 -4 2

Sample Output

0.0000
0.5000
题意:已知n个二次曲线Si(x) = ai*x^2+bi*x+c(ai >= 0),定义F(x) = max(Si(x)),求出F(x)在[0, 1000]上的最小值
思路:三分求解,三分法不仅适用于凸函数,还适用于所有单峰函数 
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 10010;

int n, a[maxn], b[maxn], c[maxn];

double F(double x) {
	double ans = a[0]*x*x + b[0]*x + c[0];
	for (int i = 1; i < n; i++)
		ans = max(ans, a[i]*x*x + b[i]*x + c[i]);
	return ans;
}

int main() {
	int t;
	scanf("%d", &t);
	while (t--) {
		scanf("%d", &n);
		for (int i = 0; i < n; i++)
			scanf("%d%d%d", &a[i], &b[i], &c[i]);

		double l = 0.0, r = 1000.0;
		for (int i = 0; i < 100; i++) {
			double m1 = l + (r - l) / 3;
			double m2 = r - (r - l) / 3;
			if (F(m1) < F(m2))
				r = m2;
			else l = m1;
		}

		printf("%.4lf\n", F(l));
	}
	return 0;
}


UVA - 1476 Error Curves (三分搜索)

标签:des   style   http   os   io   ar   for   art   div   

原文地址:http://blog.csdn.net/u011345136/article/details/39008093

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!