码迷,mamicode.com
首页 > 其他好文 > 详细

NYOJ 题目94 cigarettes

时间:2017-07-23 18:13:10      阅读:139      评论:0      收藏:0      [点我收藏+]

标签:int   each   color   ++   test   题目   大致   others   nes   

题目描述:

Tom has many cigarettes. We hypothesized that he has n cigarettes and smokes them

one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette. 
Now,do you know how many cigarettes can Tom has?

输入
First input is a single line,it‘s n and stands for there are n testdata.then there are n lines ,each line contains two integer numbers giving the values of n and k.
输出
For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.
样例输入
3
4 3
10 3
100 5
样例输出
5
14
124
大致意思是假设汤姆有n支香烟,每吸k支香烟就会得到一支新的香烟,求汤姆最多能吸多少支香烟?

#include<stdio.h>
int main()
{
int N;
scanf("%d",&N);
while(N--)
{
int n,k,i;
int sum=0;
scanf("%d %d",&n,&k);
for(i=1;i<=n;i++)
{
sum=sum+1;
if(sum%k==0)
n=n+1;
}
printf("%d",sum);
printf("\n");
}
}

//AC

欢迎各路大神评论!

 

 


NYOJ 题目94 cigarettes

标签:int   each   color   ++   test   题目   大致   others   nes   

原文地址:http://www.cnblogs.com/hys1258414454/p/7225227.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!