码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5532 Almost Sorted Array

时间:2017-07-24 13:16:51      阅读:172      评论:0      收藏:0      [点我收藏+]

标签:i++   ssi   etc   order   hdu   min   set   ase   3.1   

Almost Sorted Array

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 5478    Accepted Submission(s): 1287


Problem Description
We are all familiar with sorting algorithms: quick sort, merge sort, heap sort, insertion sort, selection sort, bubble sort, etc. But sometimes it is an overkill to use these algorithms for an almost sorted array.

We say an array is sorted if its elements are in non-decreasing order or non-increasing order. We say an array is almost sorted if we can remove exactly one element from it, and the remaining array is sorted. Now you are given an array a1,a2,,an, is it almost sorted?
 

 

Input
The first line contains an integer T indicating the total number of test cases. Each test case starts with an integer n in one line, then one line with n integers a1,a2,,an.

1T2000
2n105
1ai105
There are at most 20 test cases with n>1000.
 

 

Output
For each test case, please output "`YES`" if it is almost sorted. Otherwise, output "`NO`" (both without quotes).
 

 

Sample Input
3
3
2 1 7
3
3 2 1
5
3 1 4 1 5
 

 

Sample Output
YES
YES
NO
 注意  1 1 1 3 5 输出什么,严格递增递减排序
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <vector>
#include <iomanip>
#include <cmath>
#include <ctime>
#include <map>
#include <set>
using namespace std;
#define lowbit(x) (x&(-x))
#define max(x,y) (x>y?x:y)
#define min(x,y) (x<y?x:y)
#define MAX 100000000000000000
#define MOD 1000000007
#define pi acos(-1.0)
#define ei exp(1)
#define PI 3.141592653589793238462
#define INF 0x3f3f3f3f3f
#define mem(a) (memset(a,0,sizeof(a)))
typedef long long ll;
int x,dp[100006],dps[100006],n,t;
int a[100006];
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int ans=1;
        int pos=1;
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        dp[1]=a[0];
        for(int i=1;i<n;i++)
        {
            if(a[i]>=dp[ans]) dp[++ans]=a[i];
            else
            {
                int l=upper_bound(dp+1,dp+ans,a[i])-dp;//重要
                dp[l]=a[i];
            }
        }
        dps[1]=a[n-1];
        for(int i=n-2;i>=0;i--)
        {
            if(a[i]>=dps[pos]) dps[++pos]=a[i];
            else
            {
                int l=upper_bound(dps+1,dps+pos,a[i])-dps;
                dps[l]=a[i];
            }
        }
        if(ans>=(n-1) || pos>=(n-1)) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}

 

HDU 5532 Almost Sorted Array

标签:i++   ssi   etc   order   hdu   min   set   ase   3.1   

原文地址:http://www.cnblogs.com/shinianhuanniyijuhaojiubujian/p/7228102.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!