码迷,mamicode.com
首页 > 其他好文 > 详细

线段树 Mayor's posters

时间:2017-07-24 14:53:04      阅读:199      评论:0      收藏:0      [点我收藏+]

标签:cas   intro   href   set   val   placed   hat   divide   could not   

甚至DFS也能过吧

Mayor‘s posters POJ - 2528 

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters‘ size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 
技术分享

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4
kuangbing专题也放了这道题,确实是比较经典的线段树,但是这个还没2有涉及到修改操作
sort+lower_bound+unique离散下
#include <stdio.h>
#include <algorithm>
using  namespace std;
const int N=100100;
int b[N<<1],a[N<<1][2],bj[N<<1],M,H,bn;
int T[N*6];
void built(int n) {
    H=0;
    for(int i=1; i<n+2; i<<=1)H++;
    M=1<<H;
    for(int i=0; i<=M<<1; i++) T[i]=0;
    for(int i=1; i<=n; i++)bj[i]=0;
}
void update(int l,int r,int val) {
    for(l=l+M-1,r=r+M+1;l^r^1;l>>=1,r>>=1) {
        if(~l&1)T[l^1]=val;
        if(r&1)T[r^1]=val;
    }
}
void query(int pos) {
    int ans=0;
    for(int i=pos+M; i>0; i>>=1)
        ans=max(ans,T[i]);
    bj[ans]=1;
}
int main() {
    int t,n;
    scanf("%d",&t);
    while(t--) {
        bn=0;
        scanf("%d",&n);
        for(int i=1; i<=n; i++) {
            scanf("%d%d",&a[i][0],&a[i][1]);
            b[++bn]=a[i][0];
            b[++bn]=a[i][1];
        }
        sort(b+1,b+bn+1);
        bn=unique(b+1,b+bn+1)-b-1;
        built(bn);
        for(int i=1; i<=n; i++) {
            int l=lower_bound(b+1,b+bn+1,a[i][0])-b;
            int r=lower_bound(b+1,b+bn+1,a[i][1])-b;
            update(l,r,i);
        }
        int ans=0;
        for(int i=1; i<=bn; i++) query(i);
        for(int i=1; i<=bn; i++) if(bj[i])ans++;
        printf("%d\n",ans);
    }
    return 0;
}

 

线段树 Mayor's posters

标签:cas   intro   href   set   val   placed   hat   divide   could not   

原文地址:http://www.cnblogs.com/BobHuang/p/7228406.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!