码迷,mamicode.com
首页 > 其他好文 > 详细

Til the Cows Come Home

时间:2017-07-25 21:25:30      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:describe   rails 4   ssi   trail   strong   wal   conf   span   direct   

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John‘s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.
Output
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100
Sample Output
90
Hint
INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.
 
题目意思是让求N点到1这个点的最短距离。
求最短路问题。
一:Bellman-Ford
#include<stdio.h>
#include<queue>
#include<iostream>
#include<algorithm>

using namespace std;

int INF=99999999;

int dis[2010];

int n,m;

struct stu{
    int x,y,w;
}e[2010];

void bfs(int k)
{
    dis[1]=0;
    for(int i=1;i<=k;i++)
    {
        for(int j=1;j<=m;j++)
        {
            if(dis[e[j].x]>dis[e[j].y]+e[j].w)
                dis[e[j].x]=dis[e[j].y]+e[j].w;
            if(dis[e[j].y]>dis[e[j].x]+e[j].w)
                dis[e[j].y]=dis[e[j].x]+e[j].w;
        }
    }
}

int main()
{
    int a,b,c;
    scanf("%d%d",&m,&n);
    for(int i=1;i<=n;i++)
    {
        dis[i]=INF;
    }
    for(int i=1;i<=m;i++)
    {
        scanf("%d%d%d",&a,&b,&c);
        e[i].x=a;
        e[i].y=b;
        e[i].w=c;
    }
    bfs(n);
    printf("%d ",dis[n]);
    return 0;
}

 

二:dijkstra算法

每次找当前剩下的最小距离点

#include<stdio.h>
#include<iostream>
#include<algorithm>

using namespace std;

int inf=99999999;

int vis[2010]={0};
int dis[2010];
int m[2010][2010];

int main()
{
    int t,n,a,b,w;
    scanf("%d%d",&t,&n);
    for(int i=0;i<=n;i++)
    {
        for(int j=0;j<=n;j++)
        {
            m[i][j]=inf;
        }
        m[i][i]=0;
        dis[i]=inf;
        vis[i]=0;
    }
    for(int i=1;i<=t;i++)
    {
        scanf("%d%d%d",&a,&b,&w);
        if(m[a][b]>w)//很重要,因为有重复边
        {
            m[a][b]=w;
            m[b][a]=w;    
        }
       
    }
    for(int i=1;i<=n;i++)
        dis[i]=m[1][i];
    int f,mi;
   for(int h=1;h<=n;h++)
   {
        mi=inf;
        for(int i=1;i<=n;i++)
        {
            if(!vis[i]&&mi>dis[i])
            {
                mi=dis[i];
                f=i;
            }
        }
        vis[f]=1;
        for(int i=1;i<=n;i++)
            if(dis[i]>dis[f]+m[f][i])
                dis[i]=dis[f]+m[f][i];
   }
    printf("%d",dis[n]);
    return 0;
}

 

才开始学,看着别人的博客写都一直wr,好菜。。。

 

Til the Cows Come Home

标签:describe   rails 4   ssi   trail   strong   wal   conf   span   direct   

原文地址:http://www.cnblogs.com/xzxj/p/7235958.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!