码迷,mamicode.com
首页 > 其他好文 > 详细

Milking Time

时间:2017-07-25 22:35:12      阅读:249      评论:0      收藏:0      [点我收藏+]

标签:star   ber   ios   iostream   nes   return   imu   rate   code   

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0..N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houriN), an ending hour (starting_houri < ending_houriN), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ RN) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

* Line 1: Three space-separated integers: N, M, and R
* Lines 2..M+1: Line i+1 describes FJ‘s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

* Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input
12 4 2
1 2 8
10 12 19
3 6 24
7 10 31
Sample Output
43

这题问你在那个时间内最多能挤多少奶
从后往前面DP

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>

using namespace std;

int N,M,R;
int dp[1000010]={0};

struct st{
    int start;
    int end;
    int eff;
}a[1000010];

bool cmp(st i,st j)
{
    if(i.start<j.start)
        return true;
    return false;
}



int main()
{
    scanf("%d%d%d",&N,&M,&R);
    a[0].start=0;
    a[0].end=0;
    a[0].eff=0;
    for(int i=1;i<=M;i++)
        scanf("%d%d%d",&a[i].start,&a[i].end,&a[i].eff);
    sort(a,a+M+1,cmp);
    dp[a[M].start]=a[M].eff;
    for(int i=M;i>0;i--)
    {
        int s=dp[a[i].start];
        for(int j=a[i].start;j>=a[i-1].start;j--)
            dp[j]=s;
        if(a[i-1].end+R<=a[i].start)
            dp[a[i-1].start]=a[i-1].eff+s;
        else
            dp[a[i-1].start]=max(s,dp[a[i-1].end+R]+a[i-1].eff);
    }
   // printf("\n\n");
   // for(int i=N;i>=0;i--)
    printf("%d",dp[0]);
    //for(int i=1;i<=M;i++)
   //     printf("%d %d %d\n",a[i].start,a[i].end,a[i].eff);
    return 0;
}

 

Milking Time

标签:star   ber   ios   iostream   nes   return   imu   rate   code   

原文地址:http://www.cnblogs.com/xzxj/p/7236367.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!