码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1003

时间:2017-07-25 22:51:12      阅读:355      评论:0      收藏:0      [点我收藏+]

标签:结果   sub   记录   max sum   case   cond   输出   follow   clu   

Description

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 
 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 
 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 
 

Sample Input

2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6 
题意:
给你n个数a[1],a[2],a[3]...a[n],要你求出最大连续子段和,而且输出这个和,和这个子段的起始位置和终止位置,假设这个子段有多种可能,输出第一种结果就可以。
思路:
前段时间做个类似的题目,用的是暴力求解,用的两重循环。可是这个题目要求是n<100000,用两重循环肯定会超时,因此我们必须换一种思路,必须降低循环次数,当输入的时候,累计求和,用pos记录位置,star记录起点。end记录终点,假设sum小于0.就不必往以下累加了。

代码:
#include<cstdio>
using namespace std;
#define INF 0x7fffffff
int const maxn=100000+10;
int a[maxn];
int main()
{
    int kcase=1;
    int T,n,max,star,end,pos,sum;//max为最大字段和。star为枚举起始位置,end为枚举终止位置。sum为字段和。pos用来更新枚举起始位置
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        max=-INF;
        pos=sum=0;
        for(int i=0;i<n;i++)
            {
                scanf("%d",&a[i]);
                sum+=a[i];
                if(sum>max)
                {
                    max=sum;
                    star=pos;
                    end=i;

                }
                if(sum<0)
                {
                    sum=0;
                    pos=i+1;

                }
            }
        printf("Case %d:\n",kcase++);
        printf("%d %d %d\n",max,star+1,end+1);//数组下标是从0開始的,而数的位置是从1開始的
        if(T)
          printf("\n");
    }
    return 0;
}

hdu 1003

标签:结果   sub   记录   max sum   case   cond   输出   follow   clu   

原文地址:http://www.cnblogs.com/yxysuanfa/p/7236679.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!