码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 5444 Elven Postman(长春网路赛——平衡二叉树遍历)

时间:2017-07-26 11:37:12      阅读:184      评论:0      收藏:0      [点我收藏+]

标签:desc   else   rdl   osi   题目   src   路径   cst   site   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5444

Elven Postman

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1206    Accepted Submission(s): 681


Problem Description
Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.

So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having the privilege to see the sunrise, which matters a lot in elven culture.

Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

Your task is to determine how to reach a certain room given the sequence written on the root.

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.

技术分享
 

Input
First you are given an integer T(T10)技术分享 indicating the number of test cases.

For each test case, there is a number n(n1000)技术分享 on a line representing the number of rooms in this tree. n技术分享 integers representing the sequence written at the root follow, respectively a技术分享1技术分享,...,a技术分享n技术分享技术分享 where a技术分享1技术分享,...,a技术分享n技术分享{1,...,n}技术分享.

On the next line, there is a number q技术分享 representing the number of mails to be sent. After that, there will be q技术分享 integers x技术分享1技术分享,...,x技术分享q技术分享技术分享 indicating the destination room number of each mail.
 

Output
For each query, output a sequence of move (E技术分享 or W技术分享) the postman needs to make to deliver the mail. For that E技术分享 means that the postman should move up the eastern branch and W技术分享 the western one. If the destination is on the root, just output a blank line would suffice.

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.
 

Sample Input
2 4 2 1 4 3 3 1 2 3 6 6 5 4 3 2 1 1 1
 

Sample Output
E WE EEEEE
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:  5664 5663 5662 5661 5660 
 

题目大意:给n个结点,第一个输入的为给一个根节点,接下的一些结点比根节点小就挂在左边,比根节点大就挂在根节点的右边。以此类推。

。。。

给出q个询问。询问每一个从根节点出发到某个点的路径。

解题思路:一个点一个点的加进去就好了。和根节点进行比較,最后遍历二叉树查找就可以。


详见代码。

#include <iostream>
#include <cstdio>

using namespace std;

struct node
{
    int data;
    node *leftchild,*rightchild;
    node (int st)
    {
        data=st;
        leftchild=rightchild=NULL;
    }
};

void creat(node *root,int num)
{
    if (root->data>num)
    {
        if (root->leftchild==NULL)
        {
            node *n=new node(num);
            root->leftchild=n;
        }
        else
        {
            creat(root->leftchild,num);
        }
    }
    else
    {
        if (root->rightchild==NULL)
        {
            node *n=new node(num);
            root->rightchild=n;
        }
        else
        {
            creat(root->rightchild,num);
        }
    }
}

void get_path(node *root,int x)
{
    if (root->data==x)
    {
        puts("");
        return ;
    }
    else if (root->data>x)
    {
        putchar('E');
        get_path(root->leftchild,x);
    }
    else
    {
        putchar('W');
        get_path(root->rightchild,x);
    }
}

int main()
{
    int t;
    int a;
    scanf("%d",&t);
    while (t--)
    {
        int n;
        scanf("%d",&n);
        int st;
        scanf("%d",&st);
        node *root=new node(st);

        for (int i=1;i<n;i++)
        {
            scanf("%d",&a);
            creat(root,a);
        }
        int q,qq;
        scanf("%d",&q);
        for (int i=0;i<q;i++)
        {
            scanf("%d",&qq);
            get_path(root,qq);
        }
    }
    return 0;
}


hdu 5444 Elven Postman(长春网路赛——平衡二叉树遍历)

标签:desc   else   rdl   osi   题目   src   路径   cst   site   

原文地址:http://www.cnblogs.com/brucemengbm/p/7238457.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!