码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1364差分约束

时间:2014-09-02 22:57:45      阅读:409      评论:0      收藏:0      [点我收藏+]

标签:差分约束   最短路   

King
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 10206   Accepted: 3777

Description

Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: ``If my child was a son and if only he was a sound king.‘‘ After nine months her child was born, and indeed, she gave birth to a nice son. 
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers had to be written in a sequence and he was able to sum just continuous subsequences of the sequence. 

The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son‘s skills he decided that every problem the king had to decide about had to be presented in a form of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions. 

After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong. 

Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, ..., aSi+ni} of a sequence S = {a1, a2, ..., an}. The king thought a minute and then decided, i.e. he set for the sum aSi + aSi+1 + ... + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + ... + aSi+ni < ki or aSi + aSi+1 + ... + aSi+ni > ki resp.) and declared these constraints as his decisions. 

After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not. 

Input

The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king‘s decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100 is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described above. The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last ``null‘‘ block of the input.

Sample Input

4 2
1 2 gt 0
2 2 lt 2
1 2
1 0 gt 0
1 0 lt 0
0

Sample Output

lamentable kingdom
successful conspiracy

Source

[Submit]   [Go Back]   [Status]   [Discuss]



存.....

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<vector>
#include<string>
#include<queue>
#include<map>
#include<cmath>
#include<cstring>
using namespace std;
#define INF 1e8
const int maxn= 105;
typedef long long LL;
int d[maxn],cnt[maxn];
bool inq[maxn];

struct Edge
{
    int from,to,w;
};
vector<Edge>edges[maxn];


int n,m;
void addEdge(int u,int v,int w)
{
    edges[u].push_back((Edge)
    {
        u,v,w
    });
}

bool spfa()
{
    for(int i=0; i<=n; i++)d[i]=INF;
    d[n+1]=0;
    memset(inq,0,sizeof(inq));
    memset(cnt,0,sizeof(cnt));

    queue<int>q;
    q.push(n+1);

    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        inq[u]=false;
        for(vector<Edge>::iterator it=edges[u].begin(); it!=edges[u].end(); ++it)
        {
            Edge &e=*it;
            if(d[e.to]>d[u]+e.w)
            {
                d[e.to]=d[u]+e.w;
                if(!inq[e.to])
                {
                    cnt[e.to]++;
                    if(cnt[e.to]>n)return true;
                    q.push(e.to);
                    inq[e.to]=true;
                }
            }
        }
    }
    return false;
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        scanf("%d",&m);
        for(int i=0; i<=n; i++)edges[i].clear();

        char cmd[5];
        int x,y,w;
        for(int i=0; i<=n; i++)addEdge(n+1,i,0);
        while(m--)
        {

            scanf("%d%d%s%d",&x,&y,cmd,&w);
            if(cmd[0]=='l')
                addEdge(x-1,x+y,w-1);
            else
                addEdge(x+y,x-1,-w-1);
        }

        if(spfa())puts("successful conspiracy");
        else puts("lamentable kingdom");
    }
    return 0;
}


poj 1364差分约束

标签:差分约束   最短路   

原文地址:http://blog.csdn.net/acvcla/article/details/39012519

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!