标签:who 二分 查找 lang using each size 输入 数组
The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input
Output
Sample Input
6 -45 22 42 -16 -41 -27 56 30 -36 53 -37 77 -36 30 -75 -46 26 -38 -10 62 -32 -54 -6 45
Sample Output
5
Hint
#include<iostream>
#include<algorithm>
using namespace std;
int a[4005],b[4005],c[4005],d[4005],e[16000005],f[16000005];
int main()
{
int n;
while(cin>>n)
{
int x=0,y=0,z,t;
for(int i=0;i<n;i++)
cin>>a[i]>>b[i]>>c[i]>>d[i];
for(int i=0;i<n;i++)
for(int j=0;j<n;j++)
{
e[x++]=a[i]+b[j];
f[y++]=c[i]+d[j];
}
sort(e,e+x);
long long int s=0;
for(int i=0;i<y;i++)
{
s+=upper_bound(e,e+n*n,-f[i])-lower_bound(e,e+n*n,-f[i]);
}
cout<<s<<endl;
}
return 0;
}
POJ - 2785 :4 Values whose Sum is 0 (二分)
标签:who 二分 查找 lang using each size 输入 数组
原文地址:http://www.cnblogs.com/xibeiw/p/7240030.html