码迷,mamicode.com
首页 > 其他好文 > 详细

HDU - 2199 :Can you solve this equation? (二分)

时间:2017-07-26 18:07:14      阅读:111      评论:0      收藏:0      [点我收藏+]

标签:sam   tween   ase   lease   ios   lin   根据   should   ati   

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.InputThe first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

OutputFor each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100

Sample Input

2
100
-4

Sample Output

1.6152
No solution!

根据数学表达式用二分方法求近似解。

源代码:
#include<iostream>
#include<algorithm>
#include <iomanip>

using namespace std;

int main() {
int T,a;
cin>>T;
while(T--)
{
cin>>a;
a=a-6;
double low=0,hign=100,x,z;

if(a<0 || a>807020300)
cout<<"No solution!"<<endl;
else
{
while((hign-low)>1e-10)
{
x=(low+hign)/2;
z=8*x*x*x*x + 7*x*x*x+ 2*x*x + 3*x;
if(z>a)
hign=x;
if(z==a)
break;
if(z<a)
low=x;
}
cout<< setprecision(4)<<fixed<<x<<endl;
}

}

return 0;
}

HDU - 2199 :Can you solve this equation? (二分)

标签:sam   tween   ase   lease   ios   lin   根据   should   ati   

原文地址:http://www.cnblogs.com/xibeiw/p/7239978.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!