标签:ons include world lang put oid end pac code
题目:
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.Input
Output
Sample Input
3
1 1
2 3
4 3
Sample Output
Scenario #1: A1 Scenario #2: impossible Scenario #3: A1B3C1A2B4C2A3B1C3A4B2C4
题意:
给你一个p*q的棋盘,跳马在上面的任意一格开始移动,只能走‘日’字,问你能不能经过棋盘上面所有的格子;(百度的题意,明明是说经过所有的格子,有道硬是翻译
成了“找到一条这样的路,骑士每一次都要去一次”),输出要按照字典顺序输出
分析:
深度优先搜索,要经过所有的格子,那就肯定经过(1,1),所以就可以从(1,1)开始搜索;
AC代码:
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int t,p,q,flag;
int a[30][30];
int step[30][30];
int f[8][2]={{1,-2},{-1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
void dfs(int x,int y,int z)
{
step[z][1]=x;
step[z][2]=y;
if (z==p*q)
{
flag=1;
return ;
}
for (int i=0;i<8;i++)
{
int xi=x+f[i][0];
int yi=y+f[i][1];
if (xi>=1&&xi<=p&&yi>=1&&yi<=q&&!a[xi][yi]&&!flag)
{
a[xi][yi]=1;
dfs(xi,yi,z+1);
a[xi][yi]=0;
}
}
}
int main()
{
cin>>t;
for (int i=1;i<=t;i++)
{
flag=0;
scanf("%d%d",&p,&q);
memset(a,0,sizeof(a));
memset(step,0,sizeof(step));
a[1][1]=1;
dfs(1,1,1);
printf("Scenario #%d:\n",i);
if (flag==1)
{
for (int j=1;j<=p*q;j++)
printf("%c%d",step[j][2]+‘A‘-1,step[j][1]);
printf("\n");
}
else
printf("impossible\n");
if (i!=t)
printf("\n");
}
return 0;
}
标签:ons include world lang put oid end pac code
原文地址:http://www.cnblogs.com/lisijie/p/7243871.html