码迷,mamicode.com
首页 > 其他好文 > 详细

Big Number(简单数学题)

时间:2014-09-03 09:43:46      阅读:160      评论:0      收藏:0      [点我收藏+]

标签:数学

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26003    Accepted Submission(s): 11810


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
 

Output
The output contains the number of digits in the factorial of the integers appearing in the input.
 

Sample Input
2 10 20
 

Sample Output
7 19
 

Source
Asia 2002, Dhaka (Bengal)

意解:用对数来求n的阶乘的位数;
AC代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>

using namespace std;
typedef long long ll;

int main()
{
    int n,m;
    cin>>m;
    while(m--)
    {
        scanf("%d",&n);
        double sum = 0;
        for(int i = 1; i <= n; i++)
        {
            sum += log10((double)i);
        }
        printf("%d\n",(int)sum + 1);
    }
    return 0;
}


Big Number(简单数学题)

标签:数学

原文地址:http://blog.csdn.net/zsgg_acm/article/details/39016225

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!