码迷,mamicode.com
首页 > 其他好文 > 详细

Red and Black

时间:2017-07-31 20:11:40      阅读:162      评论:0      收藏:0      [点我收藏+]

标签:ace   amp   des   over   ons   rect   ret   character   tiles   

  There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

  The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

‘.‘ - a black tile 
‘#‘ - a red tile 
‘@‘ - a man on a black tile(appears exactly once in a data set) 
Output

  For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13
代码:
#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
using namespace std;
char a[25][25];
int v[25][25];
int fx[4]={0,0,1,-1},fy[4]={1,-1,0,0};
int m,n,e1,e2,ans;
void dfs(int x,int y)
{ v[x][y]=1;
 for(int i=0;i<4;i++)
   {int xx,yy;
    xx=x+fx[i];
    yy=y+fy[i];
    
     if(xx>=0&&yy>=0&&xx<n&&yy<m&&a[xx][yy]==.&&!v[xx][yy]) //xx<n和yy<m刚开始写反了,,,
     {ans++;
      
      dfs(xx,yy);
         
     }
   }
    
}
int main()
{
    while(scanf("%d %d",&m,&n)!=EOF&&(n||m))
    {for(int i=0;i<n;i++)
       scanf("%s",a[i]);
     memset(v,0,sizeof(v));
     for(int i=0;i<n;i++)
      {for(int j=0;j<m;j++)
        {if(a[i][j]==@)
           {e1=i;
            e2=j;
            
           
           }
            
        }
      
          
      }
      ans=1;
      dfs(e1,e2);
      printf("%d\n",ans);
        
    }
    return 0;
}

 



Red and Black

标签:ace   amp   des   over   ons   rect   ret   character   tiles   

原文地址:http://www.cnblogs.com/hss-521/p/7264671.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!