标签:nes pos first signed amp integer str 无法 技术
InputThe input starts with a positive integer P which indicates the number of test cases. Then on the following P lines,each line consists 2 positive integer m and n(0<m,n<2147483648).
OutputFor each input m n, if safe holes exist, you should output "YES", else output "NO" in a single line.
Sample Input
2
1 2
2 2
Sample Output
NO YES
题意 : 狼可以每次走m步,而这里有n个洞,问是否存在狼无法走到的洞让兔子藏身。
分析 : 只要n和m存在着最大公约数,那么狼就会一直在0,最大公约数,m的位置上循环,不会走到其他的洞上去。
这里简单讲一下最大公约数和最小公倍数的算法:
最大公约数
int gcd(int i,int j)
{
if(j==0)
return i;
else
gcd(j,i%j);
}
最小公倍数 = i*j/最大公约数;
代码:
#include <iostream>
using namespace std;
int gcd(int i,int j)
{
if(j==0)
return i;
else
gcd(j,i%j);
}
int main()
{
int T;
while(cin >> T)
{
while(T--)
{
int a,b;
cin >> a >> b;
if(gcd(a,b)==1)
cout << "NO";
else
cout << "YES";
cout << endl;
}
}
}
标签:nes pos first signed amp integer str 无法 技术
原文地址:http://www.cnblogs.com/7750-13/p/7270114.html