码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2785 4 Values whose Sum is 0

时间:2017-08-01 20:51:59      阅读:235      评论:0      收藏:0      [点我收藏+]

标签:二分   lines   desc   nes   closed   tor   code   form   div   

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n . 

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D . 

Output

For each input file, your program has to write the number quadruplets whose sum is zero. 

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

 

首先开一个数组枚举cd和,然后通过枚举ab和在新的数组里二分查找解

技术分享
#include <cstdio>
#include <cmath>
#include <cctype>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <string>
#include <stack>
#include <vector>
#include <map>
#include <set>
using namespace std;
typedef long long LL;

string s;
LL a[4005],b[4005],c[4005],d[4005];
LL cd[16000001] = {0};
LL n,res = 0;
int main() {
  // freopen("test.in","r",stdin);
  ios::sync_with_stdio(false);
  cin >> n;
  for (int i=0;i<n;i++){
    cin >> a[i] >> b[i] >> c[i] >> d[i];
  }
  for (int i=0;i<n;i++){
    for (int j=0;j<n;j++){
      cd[i*n+j] = c[i] + d[j];
    }
  }
  sort(cd,cd+n*n);
  for (int i=0;i<n;i++){
    for (int j=0;j<n;j++){
      LL now = a[i] + b[j];
      LL need = 0 - now;
      res += upper_bound(cd,cd+n*n,need) - lower_bound(cd,cd+n*n,need);
    }
  }
  cout << res;
  return 0;
}
View Code

 

poj 2785 4 Values whose Sum is 0

标签:二分   lines   desc   nes   closed   tor   code   form   div   

原文地址:http://www.cnblogs.com/ToTOrz/p/7270291.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!