码迷,mamicode.com
首页 > 其他好文 > 详细

Big Number(大整数取模)

时间:2014-09-03 16:49:46      阅读:238      评论:0      收藏:0      [点我收藏+]

标签:数学   大整数取模   

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4789    Accepted Submission(s): 3329


Problem Description
As we know, Big Number is always troublesome. But it‘s really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 

Output
For each test case, you have to ouput the result of A mod B.
 

Sample Input
2 3 12 7 152455856554521 3250
 

Sample Output
2 5 1521
 

Author
Ignatius.L
 

Source
杭电ACM省赛集训队选拔赛之热身赛

意解:大整数取模运算,类似于整数除法(手算),比如512 % 10,我们手算是51 % 10 = 1,之后1 * 10 + 2 = 12,在12 % 10  =  2,就结束了;
AC代码:
      
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>

using namespace std;
typedef long long ll;

int main()
{
    char s[1100];
    int mod,len;
    while(cin>>s>>mod)
    {
        ll sum = 0;
        len = strlen(s);
        for(int i = 0; i < len; i++)
        {
            sum = (sum * 10 + s[i] - '0') % mod;
        }
        cout<<sum<<endl;
    }
    return 0;
}


Big Number(大整数取模)

标签:数学   大整数取模   

原文地址:http://blog.csdn.net/zsgg_acm/article/details/39029317

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!