码迷,mamicode.com
首页 > 其他好文 > 详细

Virtual Friends (HDU3172)

时间:2017-08-03 20:33:12      阅读:236      评论:0      收藏:0      [点我收藏+]

标签:color   不同   return   str1   href   obb   map   case   while   

题目链接 http://acm.hdu.edu.cn/showproblem.php?pid=3172

Virtual Friends

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9227    Accepted Submission(s): 2669


Problem Description
These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends‘ friends, their friends‘ friends‘ friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends. 

Your task is to observe the interactions on such a website and keep track of the size of each person‘s network. 

Assume that every friendship is mutual. If Fred is Barney‘s friend, then Barney is also Fred‘s friend.

 

Input
Input file contains multiple test cases. 
The first line of each case indicates the number of test friendship nest.
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).

 

Output
Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.

 

Sample Input
1 3 Fred Barney Barney Betty Betty Wilma

 

Sample Output
2 3 4

 

Source

 

 

注意此题多组数据,跟正常多的多组数据不同

AC代码:
#include<cstdio>
#include<iostream>
#include<map>
#include<cstring>
using namespace std;
const int maxn= 110000;
int pre[maxn],num[maxn];
char name1[30],name2[30];
string str1,str2;
map<string,int> mmap;
int find(int x)
{
    int r=x;
    while(r!=pre[r])
        r=pre[r];
    int i=x,j;
    while(pre[i]!=r)
    {
        j=pre[i];
        pre[i]=r;
        i=j;
    }

    return r;
}
void join(int x,int y)
{
    int fx=find(x),fy=find(y);
    if(fx!=fy)
    {
        pre[fx]=fy;
        num[fy]+=num[fx];
        num[fx]=0;

    }
    printf("%d\n",num[fy]);   ///每次都要输出
}

int main()
{
    int t,n;
    while(~scanf("%d",&t))    ///多组数据
    {
        while(t--)
        {
            mmap.clear();
            scanf("%d",&n);
            for(int i=1; i<maxn; i++)
                pre[i]=i,num[i]=1;
            int no=1;
            while(n--)
            {
                scanf("%s%s",name1,name2);
                str1=name1;
                str2=name2;
                if(mmap.find(str1)==mmap.end()&&mmap.find(str2)!=mmap.end())
                {
                    mmap[str1]=no++;
                    join(mmap[str1],mmap[str2]);

                }
                else if(mmap.find(str2)==mmap.end()&&mmap.find(str1)!=mmap.end())
                {
                    mmap[str2]=no++;
                    join(mmap[str1],mmap[str2]);

                }
                else if(mmap.find(str2)==mmap.end()&&mmap.find(str1)==mmap.end())
                {
                    mmap[str1]=no++;
                    mmap[str2]=no++;
                    join(mmap[str1],mmap[str2]);


                }
                else if(mmap.find(str2)!=mmap.end()&&mmap.find(str1)!=mmap.end())
                {
                    join(mmap[str1],mmap[str2]);

                }



            }

        }
    }


    return 0;
}

 

Virtual Friends (HDU3172)

标签:color   不同   return   str1   href   obb   map   case   while   

原文地址:http://www.cnblogs.com/longl/p/7281254.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!