码迷,mamicode.com
首页 > 其他好文 > 详细

Unique Snowflakes(窗口滑动)

时间:2017-08-03 22:15:26      阅读:185      评论:0      收藏:0      [点我收藏+]

标签:重复数   and   clear   sealed   技术   class   const   otto   family   

题目:

Emily the entrepreneur has a cool business idea: packaging and selling snowflakes.

She has devised a machine that captures snowflakes as they fall, and serializes them into a stream of snowflakes that flow, one by one, into a package.

Once the package is full, it is closed and shipped to be sold. The marketing motto for the company is “bags of uniqueness.” To live up to the motto,

every snowflake in a package must be different from the others. Unfortunately, this is easier said than done, because in reality, many of the snowflakes flowing through the machine are identical.

Emily would like to know the size of the largest possible package of unique snowflakes that can be created. The machine can start filling the package at any time,

but once it starts, all snowflakes flowing from the machine must go into the package until the package is completed and sealed.

The package can be completed and sealed before all of the snowflakes have flowed out of the machine.

Input

The first line of input contains one integer specifying the number of test cases to follow.

Each test case begins with a line containing an integer n, the number of snowflakes processed by the machine.

The following n lines each contain an integer (in the range 0 to 109 , inclusive) uniquely identifying a snowflake.

Two snowflakes are identified by the same integer if and only if they are identical.

The input will contain no more than one million total snowflakes.

 

Output

For each test case output a line containing single integer, the maximum number of unique snowflakes that can be in a package.

 

 

Sample Input

1

5

1

2

3

2

1

 

Sample Output

3

 

题意:

给你一串数字,要你求最长的没有重复数字的子序列长度;

 

分析:

求没有重复数字的子序列,用set会更加方便;

窗口滑动:

left  左

right 右

left和right 初始化为1;(我的输入从1—n)

在没有找到相同元素以前,右窗口一直向右移动,碰到相同元素后,左窗口开始向右移动,在移动的同时记录下最大值

如下图(我滴天!画的好吃藕)

 技术分享

AC代码:

#include<iostream>
#include<cstring>
#include<set>
#include<cstdio>
using namespace std;
const int N=1000005;
int a[N];
int maxi (int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int t,n;
    set<int>s;
    cin>>t;
    while (t--)
    {
        s.clear();
        cin>>n;
        for (int i=1;i<=n;i++)
            cin>>a[i];
            int left=1,right=1,num=0;
            while (right<=n)
            {
                  while (right<=n&&!s.count(a[right]))
                     s.insert(a[right++]);
                num=maxi(num,right-left);
                s.erase(a[left++]);
            }
          cout << num << endl;
    }
    return 0;
}

 

Unique Snowflakes(窗口滑动)

标签:重复数   and   clear   sealed   技术   class   const   otto   family   

原文地址:http://www.cnblogs.com/lisijie/p/7281507.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!