码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1163 The Triangle (动态规划)

时间:2014-09-03 21:19:27      阅读:210      评论:0      收藏:0      [点我收藏+]

标签:acm   算法   动态规划   poj   

The Triangle
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 37778   Accepted: 22685

Description

7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right. 

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30

Source


动态规划基础题,主要掌握这种层层递推的思想,由最后一层往上递推;
题意就是从顶层的数字开始,有两个方向开始走,走到底层,输出最大的距离;
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=101;
int dp[maxn][maxn],a[maxn][maxn];
int main()
{
    int n,i,j;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
        for(j=1;j<=i;j++)
        scanf("%d",&a[i][j]);
    for(i=1;i<=n;i++)
        dp[n][i]=a[n][i];
    for(i=n-1;i>=0;i--)
        for(j=1;j<=i;j++)
        dp[i][j]=max(dp[i+1][j],dp[i+1][j+1])+a[i][j];//往上递推
    printf("%d\n",dp[1][1]);
    return 0;
}
还有一种节约内存的写法;
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=101;
int a[maxn][maxn];
int *dp;
int main()
{
    int n,i,j;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
        for(j=1;j<=i;j++)
        scanf("%d",&a[i][j]);
        dp=a[n];
    for(i=n-1;i>=0;i--)
        for(j=1;j<=i;j++)
        dp[j]=max(dp[j],dp[j+1])+a[i][j];
    printf("%d\n",dp[1]);
    return 0;
}



poj 1163 The Triangle (动态规划)

标签:acm   算法   动态规划   poj   

原文地址:http://blog.csdn.net/whjkm/article/details/39032861

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!