码迷,mamicode.com
首页 > 其他好文 > 详细

1007. Maximum Subsequence Sum (25)

时间:2017-08-05 19:02:16      阅读:146      评论:0      收藏:0      [点我收藏+]

标签:main   problem   sed   test   efi   with   ble   lin   code   

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4


在线判断,sum为负就归0,msum初值为-1,用于判断是否存在全为负的情况。

代码:
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <queue>
using namespace std;
int num[10000];
int main()
{
    int n,sum=0,s=0,e=0,z=0,msum=-1;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        cin>>num[i];
        sum+=num[i];
        if(sum<0)z=i+1,sum=0;
        else
        {
            if(sum>msum)msum=sum,s=z,e=i;
        }
    }
    if(msum>=0)
    cout<<msum<< <<num[s]<< <<num[e];
    else
    cout<<0<< <<num[0]<< <<num[n-1];
}

 

1007. Maximum Subsequence Sum (25)

标签:main   problem   sed   test   efi   with   ble   lin   code   

原文地址:http://www.cnblogs.com/8023spz/p/7290871.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!