码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1222 EXTENDED LIGHTS OUT

时间:2017-08-05 21:55:39      阅读:122      评论:0      收藏:0      [点我收藏+]

标签:sse   需要   between   put   改变   cal   hat   org   width   

EXTENDED LIGHTS OUT
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 11169   Accepted: 7133

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right. 
技术分享

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged. 
技术分享

Note: 
1. It does not matter what order the buttons are pressed. 
2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once. 
3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first 
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off. 
Write a program to solve the puzzle.

Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1‘s indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

Source

/*
* @Author: Lyucheng
* @Date:   2017-08-05 20:12:23
* @Last Modified by:   Lyucheng
* @Last Modified time: 2017-08-05 21:21:02
*/
/*
 题意:给你一个5*6的01矩阵,每次你可以反转一个元素,并且周围的四个元素跟着反转,让你找出一组解。

 思路:就像状压DP,第一行的状态确定了,接下来的状态就确定了,所以只需要枚举第一行的状态就行了
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#include <time.h>

#define MAXN 10

using namespace std;

int t;
int a[MAXN][MAXN];//初始状态
int b[MAXN][MAXN];//末尾状态
int pos[MAXN][MAXN];//保存每行的状态
const int tol=(1<<6);
bool FLAG;
inline void cal_one(int x,int i){//改变一行的状态
    for(int j=1;j<=6;j++){
        if(( ( 1<<(j-1) ) &x) !=0){//需要变换状态的
            pos[i][j]=1;
            a[i][j]=!a[i][j];
            a[i-1][j]=!a[i-1][j];
            a[i+1][j]=!a[i+1][j];
            a[i][j-1]=!a[i][j-1];
            a[i][j+1]=!a[i][j+1];
        }
    }
}

inline void cal_other(int i){//返回这一行的参数
    for(int j=1;j<=6;j++){
        if(a[i-1][j]==1){//如果上一行有1的话,这行这列必须反转一下
            pos[i][j]=1;
            //翻转
            a[i][j]=!a[i][j];
            a[i-1][j]=!a[i-1][j];
            a[i+1][j]=!a[i+1][j];
            a[i][j-1]=!a[i][j-1];
            a[i][j+1]=!a[i][j+1];
        }
    }
}

void Reset(){
    for(int i=0;i<6;i++){
        for(int j=0;j<7;j++){
            a[i][j]=b[i][j];
            pos[i][j]=0;
        }
    }
}

inline void init(){
    memset(a,0,sizeof a);
    memset(b,0,sizeof b);
}

int main(){
    // freopen("in.txt", "r", stdin);
    // freopen("out.txt", "w", stdout);
    scanf("%d",&t);
    for(int ca=1;ca<=t;ca++){
        printf("PUZZLE #%d\n",ca);
        init();
        for(int i=1;i<=5;i++){
            for(int j=1;j<=6;j++){
                scanf("%d",&b[i][j]);
            }
        }
        for(int i=0;i<tol;i++){//枚举第一行的状态
            Reset();//初始化一下a矩阵
            cal_one(i,1);
            for(int j=2;j<=5;j++){//变换剩余行的矩阵
                cal_other(j);
            }
            FLAG=true;
            for(int j=1;j<=6;j++){
                if(a[5][j]==1){
                    FLAG=false;
                    break;
                }
            }
            if(FLAG==true) break;
        }
        for(int i=1;i<=5;i++){
            for(int j=1;j<=6;j++){
                printf(j==1?"%d":" %d",pos[i][j]);
            }
            putchar(\n);
        }
    }
    return 0;
}

 

poj 1222 EXTENDED LIGHTS OUT

标签:sse   需要   between   put   改变   cal   hat   org   width   

原文地址:http://www.cnblogs.com/wuwangchuxin0924/p/7291579.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!