码迷,mamicode.com
首页 > 其他好文 > 详细

Uva401Palindromes

时间:2014-09-04 00:01:57      阅读:310      评论:0      收藏:0      [点我收藏+]

标签:style   blog   http   color   os   io   strong   ar   for   

  Palindromes 

A regular palindrome is a string of numbers or letters that is the same forward as backward. For example, the string "ABCDEDCBA" is a palindrome because it is the same when the string is read from left to right as when the string is read from right to left.

 


A mirrored string is a string for which when each of the elements of the string is changed to its reverse (if it has a reverse) and the string is read backwards the result is the same as the original string. For example, the string "3AIAE" is a mirrored string because "A" and "I" are their own reverses, and "3" and "E" are each others‘ reverses.

 


A mirrored palindrome is a string that meets the criteria of a regular palindrome and the criteria of a mirrored string. The string "ATOYOTA" is a mirrored palindrome because if the string is read backwards, the string is the same as the original and because if each of the characters is replaced by its reverse and the result is read backwards, the result is the same as the original string. Of course, "A", "T", "O", and "Y" are all their own reverses.

 


A list of all valid characters and their reverses is as follows.

 

 

Character Reverse Character Reverse Character Reverse
A A M M Y Y
B   N   Z 5
C   O O 1 1
D   P   2 S
E 3 Q   3 E
F   R   4  
G   S 2 5 Z
H H T T 6  
I I U U 7  
J L V V 8 8
K   W W 9  
L J X X    

 

 


Note that O (zero) and 0 (the letter) are considered the same character and therefore ONLY the letter "0" is a valid character.

 

Input 

Input consists of strings (one per line) each of which will consist of one to twenty valid characters. There will be no invalid characters in any of the strings. Your program should read to the end of file.

 

Output 

For each input string, you should print the string starting in column 1 immediately followed by exactly one of the following strings.

 

 

STRING CRITERIA
" -- is not a palindrome." if the string is not a palindrome and is not a mirrored string
" -- is a regular palindrome." if the string is a palindrome and is not a mirrored string
" -- is a mirrored string." if the string is not a palindrome and is a mirrored string
" -- is a mirrored palindrome." if the string is a palindrome and is a mirrored string

Note that the output line is to include the -‘s and spacing exactly as shown in the table above and demonstrated in the Sample Output below.

In addition, after each output line, you must print an empty line.

 

Sample Input 

NOTAPALINDROME 
ISAPALINILAPASI 
2A3MEAS 
ATOYOTA

 

Sample Output 

NOTAPALINDROME -- is not a palindrome.
 
ISAPALINILAPASI -- is a regular palindrome.
 
2A3MEAS -- is a mirrored string.
 
ATOYOTA -- is a mirrored palindrome.

 

 


Miguel Revilla 2001-04-16 
 
 
bubuko.com,布布扣
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int namx = 30;

bool is_mirrored(char a, char b)
{
    if((a == E && b == 3) || (a == 3 && b == E))
       return true;
    else if((a == L && b == J) || (a == J && b == L))
        return true;
    else if((a == S && b == 2) || (a == 2 && b == S))
        return true;
    else if((a == Z && b == 5) || (a == 5 && b == Z))
        return true;
    else if(a == b)
    {
        if(a == A || a == H || a == I || a == M || a == O
           || a == T || a == U || a == V || a == W || a == X
           || a == Y || a == 1 || a == 8)
        {
            return true;
        }
    }
    else
        return false;
}

int main()
{
    char str[namx];

    while(scanf("%s%*c", str) != EOF)
    {
        int len = strlen(str);
        //printf("%d\n", len);
        bool mark = true;
        bool tag = true;
        for(int i = 0; i <= len / 2; ++i)
        {
            if(str[i] != str[len-i-1])
            {
                mark = false;
                //printf("%c == %c %d\n", str[i], str[len-i-1], len-i-1);
                break;
            }
        }

        for(int i = 0; i <= len / 2; ++i)
        {
            if(!is_mirrored(str[i], str[len-i-1]))
            {
                tag = false;
                //printf("%c == %c %d\n", str[i], str[len-i-1], len-i-1);
                break;
            }
        }
        if(mark == false && tag == false)
            printf("%s -- is not a palindrome.\n", str);

        else if(mark == false && tag == true)
            printf("%s -- is a mirrored string.\n", str);

        else if(mark == true && tag == false)
            printf("%s -- is a regular palindrome.\n", str);

        else
            printf("%s -- is a mirrored palindrome.\n", str);
        printf("\n");

    }
    return 0;
}
View Code

 

一个空格, PE一晚上,淡定淡定,不要太大压力

Uva401Palindromes

标签:style   blog   http   color   os   io   strong   ar   for   

原文地址:http://www.cnblogs.com/ya-cpp/p/3955034.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!