码迷,mamicode.com
首页 > 其他好文 > 详细

题目1009:二叉搜索树

时间:2014-09-04 02:50:59      阅读:235      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   os   io   strong   ar   

时间限制:1 秒

内存限制:32 兆

特殊判题:

提交:4483

解决:2008

题目描述:
判断两序列是否为同一二叉搜索树序列
输入:
开始一个数n,(1<=n<=20) 表示有n个需要判断,n= 0 的时候输入结束。
接下去一行是一个序列,序列长度小于10,包含(0~9)的数字,没有重复数字,根据这个序列可以构造出一颗二叉搜索树。
接下去的n行有n个序列,每个序列格式跟第一个序列一样,请判断这两个序列是否能组成同一颗二叉搜索树。
输出:

如果序列相同则输出YES,否则输出NO

样例输入:
2
567432
543267
576342
0
样例输出:
YES
NO
来源:
2010年浙江大学计算机及软件工程研究生机试真题
cpp代码:
#include<iostream>
using namespace std;

int a[1024];
int b[1024];
void createtree(string s,int c[])
{
    int len=s.length();
    for(int i=0;i<len;i++)
    {
        int temp=s[i]-0;
        for(int j=1;j<=1023;)
        {
            if(c[j]==-1)
            {c[j]=temp;break;}
            else if(c[j]>temp)
            j=j*2;
            else
            j=j*2+1;    
        }
    }        
}

int main()
{
    int n,i;
    string s;
    string t;
    while(cin>>n&&n)
    {
        for(i=0;i<1024;i++) a[i]=-1;
        cin>>s;
        createtree(s,a);
        while(n--)
        {
            for(i=0;i<1024;i++) b[i]=-1;
            cin>>t;
            createtree(t,b);
            for(i=0;i<1024;i++) 
            if(a[i]!=b[i]) break;
            if(i==1024)
            cout<<"YES"<<endl;
            else
            cout<<"NO"<<endl;           
        }    
    }
    return 0;
}

静态数组模拟二叉树

题目1009:二叉搜索树

标签:des   style   blog   http   color   os   io   strong   ar   

原文地址:http://www.cnblogs.com/sairre/p/3955180.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!