标签:end stat pac other view std finally 类型 his
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 5113 Accepted: 2806
Description
Alice and Bob decide to play a new stone game.At the beginning of the game they pick n(1<=n<=10) piles of stones in a line. Alice and Bob move the stones in turn.
At each step of the game,the player choose a pile,remove at least one stones,then freely move stones from this pile to any other pile that still has stones.
For example:n=4 and the piles have (3,1,4,2) stones.If the player chose the first pile and remove one.Then it can reach the follow states.
2 1 4 2
1 2 4 2(move one stone to Pile 2)
1 1 5 2(move one stone to Pile 3)
1 1 4 3(move one stone to Pile 4)
0 2 5 2(move one stone to Pile 2 and another one to Pile 3)
0 2 4 3(move one stone to Pile 2 and another one to Pile 4)
0 1 5 3(move one stone to Pile 3 and another one to Pile 4)
0 3 4 2(move two stones to Pile 2)
0 1 6 2(move two stones to Pile 3)
0 1 4 4(move two stones to Pile 4)
Alice always moves first. Suppose that both Alice and Bob do their best in the game.
You are to write a program to determine who will finally win the game.
Input
The input contains several test cases. The first line of each test case contains an integer number n, denoting the number of piles. The following n integers describe the number of stones in each pile at the beginning of the game, you may assume the number of stones in each pile will not exceed 100.
The last test case is followed by one zero.
Output
For each test case, if Alice win the game,output 1,otherwise output 0.
Sample Input
3
2 1 3
2
1 1
0
Sample Output
1
0
如果是两个不同数量的堆。那又一定是A赢。由于A先拿。能够导致上面相等的堆的情况,而这时A、B的拿的顺序已经换过来了,所以A赢。所以这时我们会发现拿走石子能够,放回石子到其它有石子的堆里这个动作是没实用的。由于A、B都採取最好策略,每一堆石子数量比不放回的情况多是没实用的,最后也都是拿走的命。
所以就这么一直地推下去。会发现整个过程就是看石子堆是不是一对一对的过程,奇数堆的一定是A赢,偶数堆的要是一对一对就是B赢。否则就是A赢。这样代码就好写了
#include <iostream>
#include <algorithm>
#include <cmath>
using namespace std;
int n[105];
int main()
{
int num;
while(cin>>num)
{
if(!num)
break;
memset(n,0,sizeof(n));
int i,temp;
if(num%2)
{
for(i=1;i<=num;i++)
cin>>temp;
cout<<1<<endl;
}
else
{
for(i=1;i<=num;i++)
{
cin>>temp;
n[temp]++;
}
int flag=0;
for(i=0;i<=104;i++)
{
if(n[i]%2)
flag=1;
}
if(flag)
cout<<1<<endl;
else
cout<<0<<endl;
}
}
return 0;
}
标签:end stat pac other view std finally 类型 his
原文地址:http://www.cnblogs.com/cynchanpin/p/7300775.html