码迷,mamicode.com
首页 > 其他好文 > 详细

POJ2103 Jackpot(容斥+高精度)

时间:2014-09-04 11:53:19      阅读:181      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   os   io   java   ar   strong   

Jackpot
Time Limit: 20000MS   Memory Limit: 64000K
Total Submissions: 1044   Accepted: 216
Case Time Limit: 2000MS

Description

The Great Dodgers company has recently developed a brand-new playing machine. 
You put a coin into the machine and pull the handle. After that it chooses some integer number. If the chosen number is zero you win a jackpot. In the other case the machine tries to divide the chosen number by the lucky numbers p1 , p2 , . . . , pn . If at least one of the remainders is zero --- you win. 
Great Dodgers want to calculate the probability of winning on their machine. They tried to do it, but failed. So Great Dodgers hired you to write a program that calculates the corresponding probability. 
Unfortunately, probability theory does not allow you to assume that all integer numbers have equal probability. But one mathematician hinted you that the required probability can be approximated as the following limit: 
limk→∞(Sk/2k+1).

Here Sk is the number of integers between -k and k that are divisible by at least one of the lucky numbers.

Input

Input file contains n --- the number of lucky numbers (1 <= n <= 16), followed by n lucky numbers (1 <= pi <= 109 ).

Output

It is clear that the requested probability is rational. Output it as an irreducible fraction. 
On the first line of the output file print the numerator of the winning probability. On the second line print its denominator. Both numerator and denominator must be printed without leading zeroes. Remember that the fraction must be irreducible.

Sample Input

2
4 6

Sample Output

1
3
题意:给定n个数,向老虎机中投入一枚硬币,机器返回一个值X,如果X能被至少一个Pi整除,则获胜,求limk→∞(Sk/2k+1). Sk表示-k到k中能获胜的X的个数,答案用最简分数表示。
思路:简单的容斥,用JAVA大数搞定,只是要注意代码的常数级优化。TLE了一晚。。。
import java.util.*;
import java.math.*;

public class Main {
	public static BigInteger gcd(BigInteger a, BigInteger b){
		 if(b.equals(BigInteger.valueOf(0))) return a;
		 else return gcd(b,a.mod(b)); 
	}
	private static Scanner in;
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		BigInteger []num = new BigInteger[20];
		in = new Scanner(System.in);
		while(in.hasNextInt()){
			int n = in.nextInt();
			BigInteger fz = BigInteger.ZERO;
			BigInteger fm = BigInteger.ONE;
			BigInteger LCM,tmp;
			for(int i = 0; i < n; i++) {
				int k = in.nextInt();
				num[i] = BigInteger.valueOf(k);
				tmp = fm.gcd(num[i]);
				fm = fm.divide(tmp).multiply(num[i]);
			}
			
			for(int i = 1; i < (1<<n); i++) {
				int cnt = 0;
				LCM = BigInteger.ONE;
				for(int j = 0; j < n; j++) {
					if((i&(1<<j))>0) {
						tmp = num[j].gcd(LCM);
						LCM = LCM.divide(tmp).multiply(num[j]);
						cnt++;
					}
				}
				LCM = fm.divide(LCM);
				if((cnt&1)!=0) {
					fz = fz.add(LCM);
				}else{
					fz = fz.subtract(LCM);
				}
			}
			BigInteger GCD = gcd(fz,fm);
			fm = fm.divide(GCD);
			fz = fz.divide(GCD);
			System.out.println(fz);
			System.out.println(fm);
		}
	}
}


POJ2103 Jackpot(容斥+高精度)

标签:des   style   blog   color   os   io   java   ar   strong   

原文地址:http://blog.csdn.net/mowayao/article/details/39049395

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!