码迷,mamicode.com
首页 > 其他好文 > 详细

验证子串

时间:2017-08-09 19:15:44      阅读:244      评论:0      收藏:0      [点我收藏+]

标签:for   题目   amp   problem   第一个   pre   include   ddn   string   

验证子串


链接:http://ybt.ssoier.cn:8088/problem_show.php?pid=1140

【题目描述】

输入两个字符串,验证其中一个串是否为另一个串的子串。

【输入】

输入两个字符串, 每个字符串占一行,长度不超过200且不含空格。

【输出】

若第一个串s1是第二个串s2的子串,则输出(s1) is substring of (s2)

否则,若第二个串s2是第一个串s1的子串,输出(s2) is substring of (s1)

否则,输出 No substring。

 

【输入样例】

abc
dddncabca

【输出样例】

abc is substring of dddncabca
#include<iostream>

using namespace std;

void cmp(string a,int la,string b,int lb){
    int flag=0;
    for(int i=0;i<la;i++){
        int j=0,m=i;
        while(a[m++]==b[j++]&&a[m-1]!=\0)continue;
        if(j==lb+1){
            cout<<b<<" is substring of "<<a<<endl;flag=1;break;
        }
    }
    if(!flag)cout<<"No substring"<<endl;
}

int main(){
    string s1,s2;
    cin>>s1>>s2;
    int l1=s1.size(),l2=s2.size();
    if(l1>=l2) cmp(s1,l1,s2,l2);
    else if(l1<l2) cmp(s2,l2,s1,l1);
} 

 

验证子串

标签:for   题目   amp   problem   第一个   pre   include   ddn   string   

原文地址:http://www.cnblogs.com/EdSheeran/p/7326986.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!