码迷,mamicode.com
首页 > 其他好文 > 详细

bitset优化FLOYD HDU 3275

时间:2017-08-09 19:58:01      阅读:487      评论:0      收藏:0      [点我收藏+]

标签:rect   str   fas   好的   tac   tween   type   spec   output   

Each of Farmer John‘s N cows (1 ≤ N ≤ 1,000) produces milk at a different positive rate, and FJ would like to order his cows according to these rates from the fastest milk producer to the slowest.

FJ has already compared the milk output rate for M (1 ≤ M ≤ 10,000) pairs of cows. He wants to make a list of C additional pairs of cows such that, if he now compares those C pairs, he will definitely be able to deduce the correct ordering of all N cows. Please help him determine the minimum value of C for which such a list is possible.

Input

Line 1: Two space-separated integers: N and M 
Lines 2.. M+1: Two space-separated integers, respectively: X and Y. Both X and Y are in the range 1... N and describe a comparison where cow X was ranked higher than cow Y.

Output

Line 1: A single integer that is the minimum value of C.

Sample Input

5 5
2 1
1 5
2 3
1 4
3 4

Sample Output

3

Hint

From the information in the 5 test results, Farmer John knows that since cow 2 > cow 1 > cow 5 and cow 2 > cow 3 > cow 4, cow 2 has the highest rank. However, he needs to know whether cow 1 > cow 3 to determine the cow with the second highest rank. Also, he will need one more question to determine the ordering between cow 4 and cow 5. After that, he will need to know if cow 5 > cow 3 if cow 1 has higher rank than cow 3. He will have to ask three questions in order to be sure he has the rankings: "Is cow 1 > cow 3? Is cow 4 > cow 5? Is cow 5 > cow 3?"
#include<iostream>
#include<cstdio>
#include<queue>
#include<algorithm>
#include<cstring>
#include<string>
#include<bitset>
#include<stack>
using namespace std;
typedef long long LL;
#define MAXN 1009
#define N 100
#define INF 0x3f3f3f3f
/*
传递闭包关系
如果排序好的数字 它们之间已经知道的关系数目肯定是C(n,2)
ans 就是     C(n,2) - 现在已经知道的关系数目
现在已经知道的关系可以DFS 也可以Floyd
*/
bitset<MAXN> g[MAXN];
int n, m;
void Floyd()
{
    for (int i = 1; i <= n; i++)
    {
        for (int j = 1; j <= n; j++)
            if (g[j][i])
                g[j] |= g[i];
    }
}
int main()
{
    scanf("%d%d", &n, &m);
    int f, t;
    while (m--)
    {
        scanf("%d%d", &f, &t);
        g[f][t] = true;
    }
    Floyd();
    int ans = 0;
    for (int i = 1; i <= n; i++)
    {
        for (int j = i+1; j <= n; j++)
        {
            if (!g[i][j]&&!g[j][i]) ans++;
        }
    }
    printf("%d\n",  ans );
}

 

bitset优化FLOYD HDU 3275

标签:rect   str   fas   好的   tac   tween   type   spec   output   

原文地址:http://www.cnblogs.com/joeylee97/p/7327250.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!