码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1113 Wall(标准的凸包果题)

时间:2014-09-04 22:23:40      阅读:251      评论:0      收藏:0      [点我收藏+]

标签:poj   凸包   

题目链接:http://poj.org/problem?id=1113


Description

Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King‘s castle. The King was so greedy, that he would not listen to his Architect‘s proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall. 
bubuko.com,布布扣

Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King‘s requirements. 

The task is somewhat simplified by the fact, that the King‘s castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle‘s vertices in feet.

Input

The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King‘s castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle. 

Next N lines describe coordinates of castle‘s vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.

Output

Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King‘s requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

Sample Input

9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200

Sample Output

1628

Hint

结果四舍五入就可以了

Source


标准的凸包果题!


题意:求得n个点的凸包后,然后求与凸包相距为L的外圈的周长。

思路:画图后可知,最后所求的周长就是等于凸包周长+半径为L的圆的周长。

附图片一张(转载):

bubuko.com,布布扣


有点坑的地方就是最后答案定义double 输出%.0lf会WA, 换成float %.0f 就AC!

代码如下:

//#pragma warning (disable:4786)
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <cstdlib>
#include <climits>
#include <ctype.h>
#include <queue>
#include <stack>
#include <vector>
#include <utility>
#include <deque>
#include <set>
#include <map>
#include <iostream>
#include <algorithm>
using namespace std;
const double eps = 1e-9;
//const double pi = atan(1.0)*4;
const double pi = 3.1415926535897932384626;
#define INF 1e18
//typedef long long LL;
//typedef __int64 LL;
const int MAXN = 1017;

struct point
{
    int x,y;
} e[MAXN],res[MAXN]; //坐标点集,位于凸包上的点

bool cmp(point a,point b)//排序方法
{
    if(a.x == b.x)
        return a.y < b.y;
    return a.x < b.x;
}

int cross(point a,point b,point c)//叉积(向量积)
{
    return (a.x-c.x)*(b.y-c.y)-(b.x-c.x)*(a.y-c.y);
}

double lenght(point a,point b)//距离
{
    return sqrt(1.0*(a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}

int convex(int n)//求凸包上的点
{
    sort(e,e+n,cmp);
    int m=0, i, k;
    //求下凸包,逆时针
    for(i = 0; i < n; i++)
    {
        while(m>1 && cross(res[m-1],e[i],res[m-2])<=0)
            m--;
        res[m++]=e[i];
    }
    k = m;
    //求上凸包
    for(i = n-2; i >= 0; i--)
    {
        while(m>k && cross(res[m-1],e[i],res[m-2])<=0)
            m--;
        res[m++]=e[i];
    }
    if(n > 1)//起始点重复。
        m--;
    return m;
}

int main()
{
    int n, m, L;
    scanf("%d%d",&n,&L);
    for(int i = 0; i < n; i++)
        scanf("%d%d",&e[i].x,&e[i].y);
    m = convex(n);
    float ans = 0;
    for(int i = 1; i < m; i++)//求凸包的周长
        ans+=lenght(res[i],res[i-1]);
    ans+=lenght(res[m-1],res[0]);//首尾相接
    ans+=2*pi*L;//加上以L为半径的圆的周长

    printf("%.0f\n",ans);
    return 0;
}


poj 1113 Wall(标准的凸包果题)

标签:poj   凸包   

原文地址:http://blog.csdn.net/u012860063/article/details/39059469

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!