码迷,mamicode.com
首页 > 其他好文 > 详细

Pagodas 等差数列

时间:2017-08-19 10:56:00      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:nal   http   integer   ase   element   inpu   tac   rebuild   from   

nn pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from 11 to nn. However, only two of them (labelled aa and bb, where 1abn1≤a≠b≤n) withstood the test of time. 

Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled i (i?{a,b} and 1in)i (i?{a,b} and 1≤i≤n) if there exist two pagodas standing erect, labelled jj and kkrespectively, such that i=j+ki=j+k or i=j?ki=j?k. Each pagoda can not be rebuilt twice. 

This is a game for them. The monk who can not rebuild a new pagoda will lose the game.

InputThe first line contains an integer t (1t500)t (1≤t≤500) which is the number of test cases. 
For each test case, the first line provides the positive integer n (2n20000)n (2≤n≤20000) and two different integers aa and bb.
OutputFor each test case, output the winner (``Yuwgna" or ``Iaka"). Both of them will make the best possible decision each time.Sample Input

16
2 1 2
3 1 3
67 1 2
100 1 2
8 6 8
9 6 8
10 6 8
11 6 8
12 6 8
13 6 8
14 6 8
15 6 8
16 6 8
1314 6 8
1994 1 13
1994 7 12

Sample Output

Case #1: Iaka
Case #2: Yuwgna
Case #3: Yuwgna
Case #4: Iaka
Case #5: Iaka
Case #6: Iaka
Case #7: Yuwgna
Case #8: Yuwgna
Case #9: Iaka
Case #10: Iaka
Case #11: Yuwgna
Case #12: Yuwgna
Case #13: Iaka
Case #14: Yuwgna
Case #15: Iaka
Case #16: Iaka

n个数字相加或者相减得出的数列是gcd(a,b)的等差数列,求出有几项就OK了
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<sstream>
#include<algorithm>
#include<queue>
#include<vector>
#include<cmath>
#include<map>
#include<stack>
#include<fstream>
#include<set>
#include<memory>
#include<bitset>
#include<string>
#include<functional>
using namespace std;
typedef long long LL;

int T, a, b, n;
int gcd(int a, int b)
{
    if (b == 0)
        return a;
    else
        return gcd(b, a%b);
}
int main()
{
    scanf("%d", &T);
    for(int cas = 1;cas<=T;cas++)
    {
        scanf("%d%d%d",  &n,&a ,&b);
        if (!((n / gcd(a, b)) & 1))
            printf("Case #%d: Iaka\n", cas);
        else
            printf("Case #%d: Yuwgna\n", cas);
    }
}

 

Pagodas 等差数列

标签:nal   http   integer   ase   element   inpu   tac   rebuild   from   

原文地址:http://www.cnblogs.com/joeylee97/p/7395406.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!