码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1698 Just a Hook

时间:2017-08-19 22:27:10      阅读:160      评论:0      收藏:0      [点我收藏+]

标签:wan   integer   test   dota   search   turn   memset   技术分享   src   

Just a Hook

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 34697    Accepted Submission(s): 16938


Problem Description
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.

技术分享


Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.
The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.
For each silver stick, the value is 2.
For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.
You may consider the original hook is made up of cupreous sticks.
 

 

Input
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.
For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.
Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind.
 

 

Output
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.
 

 

Sample Input
1 10 2 1 5 2 5 9 3
 

 

Sample Output
Case 1: The total value of the hook is 24.
 

 

Source
 

 

Recommend
wangye   |   We have carefully selected several similar problems for you:  1166 1754 1542 1394 2795 
思路:线段树区间修改
又是一道洪水题(到底该怎么说呢??╮(╯▽╰)╭,这个题目,他这个吧!又卡cin)
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int T,n,m,tot;
struct nond{
    int l,r;
    int sum,falg;
}tree[101000*4];
void up(int now){
    tree[now].sum=tree[now<<1].sum+tree[now<<1|1].sum;
}
void build(int now,int l,int r){
    tree[now].l=l;
    tree[now].r=r;
    if(tree[now].l==tree[now].r){
        tree[now].sum=1;
        return ;
    }
    int mid=(tree[now].l+tree[now].r)>>1;
    build(now<<1,l,mid);
    build(now<<1|1,mid+1,r);
    up(now);
}
void down(int now){
    tree[now<<1].sum=(tree[now<<1].r-tree[now<<1].l+1)*tree[now].falg;
    tree[now<<1|1].sum=(tree[now<<1|1].r-tree[now<<1|1].l+1)*tree[now].falg;
    tree[now<<1].falg=tree[now<<1|1].falg=tree[now].falg;
    tree[now].falg=0;
}
void change(int now,int l,int r,int x){
    if(tree[now].l==l&&tree[now].r==r){
        tree[now].sum=(tree[now].r-tree[now].l+1)*x;
        tree[now].falg=x;
        return;
    }
    if(tree[now].falg)    down(now);
    int mid=(tree[now].l+tree[now].r)>>1;
    if(r<=mid)    change(now<<1,l,r,x);
    else if(l>mid)    change(now<<1|1,l,r,x);
    else{
        change(now<<1,l,mid,x);
        change(now<<1|1,mid+1,r,x);
    }
    up(now);
}
int main(){
    scanf("%d",&T);
    while(T--){
        scanf("%d",&n);tot++;
        memset(tree,0,sizeof(tree));
        build(1,1,n);
        scanf("%d",&m);
        for(int i=1;i<=m;i++){
            int x,y,z;
            scanf("%d%d%d",&x,&y,&z);
            change(1,x,y,z);
        }
        printf("Case %d: The total value of the hook is %d.\n",tot,tree[1].sum);
    }
}

 

hdu 1698 Just a Hook

标签:wan   integer   test   dota   search   turn   memset   技术分享   src   

原文地址:http://www.cnblogs.com/cangT-Tlan/p/7397849.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!