码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 6153 A Secret

时间:2017-08-20 11:21:52      阅读:187      评论:0      收藏:0      [点我收藏+]

标签:key   find   class   amp   char   str   lines   fine   name   

A Secret

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 256000/256000 K (Java/Others)
Total Submission(s): 817    Accepted Submission(s): 321

Problem Description
Today is the birthday of SF,so VS gives two strings S1,S2 to SF as a present,which have a big secret.SF is interested in this secret and ask VS how to get it.There are the things that VS tell:
  Suffix(S2,i) = S2[i...len].Ni is the times that Suffix(S2,i) occurs in S1 and Li is the length of Suffix(S2,i).Then the secret is the sum of the product of Ni and Li.
  Now SF wants you to help him find the secret.The answer may be very large, so the answer should mod 1000000007.
 
Input
Input contains multiple cases.
  The first line contains an integer T,the number of cases.Then following T cases.
  Each test case contains two lines.The first line contains a string S1.The second line contains a string S2.
  1<=T<=10.1<=|S1|,|S2|<=1e6.S1 and S2 only consist of lowercase ,uppercase letter.
 
Output
For each test case,output a single line containing a integer,the answer of test case.
  The answer may be very large, so the answer should mod 1e9+7.
 
Sample Input
2
aaaaa
aa
abababab
aba
 
Sample Output
13
19
Hint
case 2: Suffix(S2,1) = "aba", Suffix(S2,2) = "ba", Suffix(S2,3) = "a". N1 = 3, N2 = 3, N3 = 4. L1 = 3, L2 = 2, L3 = 1. ans = (3*3+3*2+4*1)%1000000007.
 
Source
题目容易理解,匹配个数
#include <iostream> 
#include <algorithm> 
#include <cstring> 
#include <cstdio>
#include <vector> 
#include <queue> 
#include <cstdlib> 
#include <iomanip>
#include <cmath>
#include <cassert>
#include <ctime> 
#include <map> 
#include <set> 
using namespace std; 
#define lowbit(x) (x&(-x)) 
#define max(x,y) (x>y?x:y) 
#define min(x,y) (x<y?x:y) 
#define MAX 100000000000000000 
#define MOD 1000000007
#define pi acos(-1.0) 
#define ei exp(1) 
#define PI 3.141592653589793238462
#define ios() ios::sync_with_stdio(false)
#define INF 1044266558
#define mem(a) (memset(a,0,sizeof(a)))
typedef long long ll;
const int maxn=1e6+7;
ll t,la,lb,i,j,k;
char sa[maxn],sb[maxn];
ll nex[maxn],val[maxn];
void getnext()
{
    memset(nex,0,sizeof(nex));
    memset(val,0,sizeof(val));
    nex[0]=-1;
    for(i=0;i<lb;i++)
    {
        j=nex[i];
        val[i+1]=i+1;
        while(j>-1)
        {
            if(sb[j]==sb[i]) {nex[i+1]=j+1,val[i+1]+=val[j+1],val[i+1]%=MOD;break;}
            j=nex[j];
        }
    }
    /*for(i=1;i<=lb;i++)
    {
        printf("%lld ",val[i]);
    }
    printf("\n");*/
}
ll matchfind()
{
    ll ans=0;
    k=0;
    for(i=0;i<la;i++)
    {
        j=k;
        for(k=0;j>=0;j=nex[j])
        {
            if(sa[i]==sb[j])
            {
                k=j+1;
                break;
            }
        }
        ans=(ans+val[k])%MOD;
    }
    return ans;
}
int main()
{
    scanf("%lld",&t);
    while(t--)
    {
        scanf("%s %s",sa,sb);
        la=strlen(sa),lb=strlen(sb);
        reverse(sa,sa+la),reverse(sb,sb+lb);
        getnext();
        printf("%lld\n",matchfind());
    }
    return 0;
}
/*
       a     b     a     b     b     b     a     b     a 
next   0     0     1     2     0     0     1     2     3
val    1     2     4     6     5     6     8     10    13
valfj  1     2     3+1   4+2   5     6     7+1   8+2   9+4=9+3+1::next[9]=next[3]=next[1];
*/

 

HDU 6153 A Secret

标签:key   find   class   amp   char   str   lines   fine   name   

原文地址:http://www.cnblogs.com/shinianhuanniyijuhaojiubujian/p/7399163.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!