码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1251 统计难题

时间:2017-08-20 21:08:09      阅读:191      评论:0      收藏:0      [点我收藏+]

标签:span   思路   nan   define   前缀   pid   单词   auth   limit   

统计难题

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 131070/65535 K (Java/Others)
Total Submission(s): 43840    Accepted Submission(s): 15713

 

Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 
Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 
Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 
Sample Input
banana band bee absolute acm ba b band abc
 
Sample Output
2 3 1 0
 
Author
Ignatius.L
 

 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:  1075 1247 1671 1298 1800 
思路:裸的trie树
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define MAXN 400001
using namespace std;
char s[11];
bool p;
int root,tot,len,sum[MAXN],trie[MAXN][27];
void insert(){
    len=strlen(s);
    root=0;
    for(int i=0;i<len;i++){
        int x=s[i]-a;
        if(!trie[root][x])    trie[root][x]=++tot;
        sum[trie[root][x]]++;
        root=trie[root][x];
    }
}
int find(){
    root=0;
    len=strlen(s);
    for(int i=0;i<len;i++){
        int x=s[i]-a;
        if(!trie[root][x])    return 0;
        root=trie[root][x];
    }
    return sum[root];
}
int main(){
    while(gets(s)){
        if(!p){
            if(strlen(s))    insert();
            else p=1;
        }
        else printf("%d\n",find());
    }    
}

 

HDU 1251 统计难题

标签:span   思路   nan   define   前缀   pid   单词   auth   limit   

原文地址:http://www.cnblogs.com/cangT-Tlan/p/7401145.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!