码迷,mamicode.com
首页 > 其他好文 > 详细

E - A strange lift 【BFS】

时间:2017-08-21 20:39:12      阅读:152      评论:0      收藏:0      [点我收藏+]

标签:cond   problem   tput   sed   tran   isp   single   input   size   

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can‘t go up high than N,and can‘t go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you‘ll go up to the 4 th floor,and if you press the button "DOWN", the lift can‘t do it, because it can‘t go down to the -2 th floor,as you know ,the -2 th floor isn‘t exist. 
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"? 

InputThe input consists of several test cases.,Each test case contains two lines. 
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn. 
A single 0 indicate the end of the input.OutputFor each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can‘t reach floor B,printf "-1".Sample Input

5 1 5
3 3 1 2 5
0

Sample Output

3
技术分享
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
#define ll long long
#define inf 0x3fffffff
using namespace std;
struct Node
{
    int floor;
    int step;
};

int f[205];
int vis[205];
int dir[2]={-1,1};
int n,a,b;
queue<Node> q;
int bfs()
{
    while(!q.empty())
        q.pop();

    q.push(Node{a,0});
    while(!q.empty())
    {
        Node tmp;
        Node u=q.front();
        q.pop();
        if(u.floor==b)//到达
        {
            return u.step;
        }
        for(int i=0;i<2;i++)
        {
            tmp.floor=u.floor+f[u.floor]*dir[i];
            tmp.step=u.step+1;
            if(tmp.floor>=1&&tmp.floor<=n&&!vis[tmp.floor])
                {
                    vis[tmp.floor]=1;
                    q.push(tmp);
                }
        }
    }
    return -1;
}

int main()
{
    while(~scanf("%d",&n)&&n)
    {
        scanf("%d%d",&a,&b);
        memset(vis,0,sizeof(vis));
        for(int i=1;i<=n;i++)
            scanf("%d",&f[i]);
        printf("%d\n",bfs());
    }
    return 0;
}
View Code

 

E - A strange lift 【BFS】

标签:cond   problem   tput   sed   tran   isp   single   input   size   

原文地址:http://www.cnblogs.com/Roni-i/p/7406277.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!