码迷,mamicode.com
首页 > 其他好文 > 详细

数塔 Easy

时间:2017-08-21 21:56:58      阅读:238      评论:0      收藏:0      [点我收藏+]

标签:算法   algo   str   https   cst   print   while   例子   tput   

在讲述DP算法的时候,一个经典的例子就是数塔问题,它是这样描述的: 

有如下所示的数塔,要求从顶层走到底层,若每一步只能走到相邻的结点,则经过的结点的数字之和最大是多少? 
技术分享 
已经告诉你了,这是个DP的题目,你能AC吗?

Input输入数据首先包括一个整数C,表示测试实例的个数,每个测试实例的第一行是一个整数N(1 <= N <= 100),表示数塔的高度,接下来用N行数字表示数塔,其中第i行有个i个整数,且所有的整数均在区间[0,99]内。 
Output对于每个测试实例,输出可能得到的最大和,每个实例的输出占一行。 
Sample Input

1
5
7
3 8
8 1 0 
2 7 4 4
4 5 2 6 5

Sample Output

30
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;
const int N = 100 + 5;
int dp[N][N];

void Solve_question(int n){
    for(int i = n-1; i >= 1; i--)
        for(int j = 1; j <= i; j++){
            dp[i][j] += max(dp[i+1][j], dp[i+1][j+1]);
    }
    printf("%d\n", dp[1][1]);
}
void Input_data(int n){
    for(int i = 1; i <= n; i++)
        for(int j = 1; j <= i; j++) scanf("%d", &dp[i][j]);
}
int main(){
    int T, n;
    scanf("%d", &T);
    while(T--){
        scanf("%d", &n);
        Input_data(n);
        Solve_question(n);
    }
    return 0;
}

 

数塔 Easy

标签:算法   algo   str   https   cst   print   while   例子   tput   

原文地址:http://www.cnblogs.com/Pretty9/p/7406838.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!