码迷,mamicode.com
首页 > 其他好文 > 详细

最大连续和 Easy

时间:2017-08-21 21:57:08      阅读:263      评论:0      收藏:0      [点我收藏+]

标签:bsp   class   pre   art   cst   tween   span   test   cal   

Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14. 

InputThe first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000). 
OutputFor each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases. 
Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6
#include<iostream>
#include<cstring>
#include<cstdio>

using namespace std;

void Solve(){
    int n, x, st, h = 1, t = 1, tmp, ans = 0;
    static int Case = 0;
    scanf("%d", &n);
    for(int i = 1; i <= n; i++){
        scanf("%d", &x);
        if(i == 1){
            st = t = 1;
            tmp = ans = x;
        }else{
            if(x > tmp + x){
                st = i;
                tmp = x;
            }else tmp += x;
        }
        if(tmp > ans){
            h = st, t = i;
            ans = tmp;
        }
    }
    printf("Case %d:\n%d %d %d\n", ++Case, ans, h, t);
}
int main(){
    int T;
    scanf("%d", &T);
    while(T--){
        Solve();
        if(T) printf("\n");
    }
}

 

最大连续和 Easy

标签:bsp   class   pre   art   cst   tween   span   test   cal   

原文地址:http://www.cnblogs.com/Pretty9/p/7406849.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!